Bug 1562315

Summary: Subpackage variants to reduce default installed footprint for Live images
Product: [Fedora] Fedora Reporter: Jens Petersen <petersen>
Component: google-noto-cjk-fontsAssignee: Peng Wu <pwu>
Status: CLOSED DEFERRED QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 28CC: i18n-bugs, psatpute, pwu, tagoh
Target Milestone: ---Keywords: i18n
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-04-09 06:02:16 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jens Petersen 2018-03-30 06:18:42 UTC
Description of problem:
F28 Beta Live images increased about 300MB in size due to
the large number of variants of the new Noto CJK font families.
Can we subpackage out the variants other than Regular to make
the default installs back to the same size as F27?

Comment 1 Jens Petersen 2018-03-30 06:29:45 UTC
Fedora-Workstation-Live-x86_64-27-1.6.iso  1.5G
Fedora-Workstation-Live-x86_64-28_Beta-1.3.iso  1.8G

Comment 2 Akira TAGOH 2018-03-30 07:47:27 UTC
proposed on the list to move extra variants into the sub-package.

estimation:
font sizes for CJK fonts installed by default on f27:
$ rpm -qlva vlgothic-fonts naver-nanum-gothic-fonts
adobe-source-han-*-{cn,tw}-fonts | grep -E 'ttf|otf'|awk
'BEGIN{a=0}{a+=$5}END{print a}'
235970044

font sizes for CJK on f28 so far:
$ rpm -qlva google-noto-*-{jp,kr,tc,sc}-fonts | awk
'BEGIN{a=0}{a+=$5}END{print a}'
508140498

Proposed workaround - font sizes for CJK fonts with Regular only on f28:
$ rpm -qlva google-noto-*-{jp,kr,tc,sc}-fonts | grep Regular | awk
'BEGIN{a=0}{a+=$5}END{print a}'
119507812

another - font sizes for CJK fonts with Regular and Bold only on f28:
$ rpm -qlva google-noto-*-{jp,kr,tc,sc}-fonts | grep -E
'Regular|\-Bold\.' | awk 'BEGIN{a=0}{a+=$5}END{print a}'
243328916

Comment 3 Akira TAGOH 2018-04-09 07:38:08 UTC
another proposal to replace with ttc:
$ rpm -qlva google-noto-*-cjk-ttc-fonts | grep ttc | awk 'BEGIN{a=0}{a+=$5}END{print a}'
298130189

No regressions will be made from the POV of typefaces availability but will saves about 210MB.

Comment 4 Jens Petersen 2018-04-09 15:56:19 UTC
See also https://pagure.io/fedora-workstation/issue/46

Comment 5 Jens Petersen 2019-04-09 06:02:16 UTC
Probably variable fonts will be a better solution when they become available.