Bug 1562344

Summary: Unneeded/wrong repository used in the sahara-image-elements script for RHEL image
Product: Red Hat OpenStack Reporter: Luigi Toscano <ltoscano>
Component: sahara-image-elementsAssignee: Telles Nobrega <tenobreg>
Status: CLOSED ERRATA QA Contact: Luigi Toscano <ltoscano>
Severity: high Docs Contact:
Priority: high    
Version: 13.0 (Queens)CC: jschluet, matt
Target Milestone: betaKeywords: Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: sahara-image-elements-8.0.1-0.20180316135144.c235e1e.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1562346 (view as bug list) Environment:
Last Closed: 2018-06-27 13:49:35 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1562346    

Description Luigi Toscano 2018-03-30 09:30:05 UTC
Description of problem:
The build script sahara-image-elements register the images to few repositories. One of those seems to be not needed anymore from 12 onwards, and when available it causes issues because one of the packages (openstack-selinux) depends on an additional package which is in a available only in rhel-7-server-extras-rpms.
On the other side, openstack-selinux is not needed on the hadoop images (it is skipped if not available), so instead of adding rhel-7-server-extras-rpms, I would remove rhel-7-server-openstack-11-rpms from diskimage-create.sh
(and probably make it possible to override REG_REPOS).

Version-Release number of selected component (if applicable):
sahara-image-elements-8.0.1-0.20180316135143.c235e1e.el7ost.noarch.rpm  

Workaround:
sed -i 's/ rhel-7-server-openstack-11-rpms//' /usr/bin/diskimage-create.sh

Comment 3 Luigi Toscano 2018-04-24 16:19:25 UTC
The repository is not required anymore.

Tested with:
sahara-image-elements-8.0.1-0.20180316135144.c235e1e

Comment 5 errata-xmlrpc 2018-06-27 13:49:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086