Bug 1563373

Summary: FFU: WARN the user that the procedure should be tried in a test environment
Product: Red Hat OpenStack Reporter: Marius Cornea <mcornea>
Component: python-tripleoclientAssignee: Marios Andreou <mandreou>
Status: CLOSED ERRATA QA Contact: Marius Cornea <mcornea>
Severity: medium Docs Contact:
Priority: medium    
Version: 13.0 (Queens)CC: aschultz, ccamacho, dbecker, hbrock, jslagle, mandreou, mbracho, mburns, morazi, rhel-osp-director-maint, sathlang
Target Milestone: betaKeywords: Triaged
Target Release: 13.0 (Queens)Flags: mbracho: needinfo+
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-tripleoclient-9.2.1-4.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:50:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Marius Cornea 2018-04-03 18:40:48 UTC
Description of problem:

Per the FFU MVP definition we need to warn the operator to run the procedure on a test environment before running it on production:

"The framework will include the ability to clearly WARN the user that this procedure should be tried in a test environment and that an announcement to try in production will come in after. 
This warning should be easily changeable as the situation changes in future z-streams."

Comment 2 Marios Andreou 2018-04-24 15:14:26 UTC
re-assigning to Dan and changing component to documentation

Comment 3 Marios Andreou 2018-04-24 15:24:57 UTC
taking back after irc chat just now thanks mcornea

Comment 4 Marios Andreou 2018-04-26 12:28:00 UTC
posting for discussion 

https://review.openstack.org/564479 Add warning + required input for ffwd-upgrade cli --yes to skip

Comment 12 Marius Cornea 2018-05-17 19:11:40 UTC
Warning! The TripleO Fast Forward Upgrade workflow is currently considered under development. In particular invocations of the ffwd-upgrade cli should be initially limited to development/test environments. Once and if you decide to use ffwd-upgrade in production, ensure you are adequately prepared with valid backup of your current deployment state.
Proceed with the fast forward upgrade? Type 'yes' to continue and anything else to cancel. Consider using the --yes parameter if you wish to skip this warning in future.

Comment 14 errata-xmlrpc 2018-06-27 13:50:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086