Bug 1563553

Summary: [Doc][Ubuntu Upgrade guide] - need change in ceph-ansible upgrade command
Product: Red Hat Ceph Storage Reporter: Parikshith <pbyregow>
Component: DocumentationAssignee: Erin Donnelly <edonnell>
Status: CLOSED CURRENTRELEASE QA Contact: ceph-qe-bugs <ceph-qe-bugs>
Severity: low Docs Contact:
Priority: unspecified    
Version: 3.0CC: asriram, edonnell, kdreyer
Target Milestone: rc   
Target Release: 3.*   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-08-26 06:55:39 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Parikshith 2018-04-04 07:33:00 UTC
Description of problem:

"sudo apt-get upgrade ceph-ansible" tries to upgrade ceph packages along with ceph-ansible and errors out. Needs command change in 3.x ubuntu upgrade guide as mentioned below:

From:
If upgrading from Ceph 3.x to the latest version, on the Ansible administration node, ensure the latest version of the ceph-ansible package is installed.

[root@admin ~]$ sudo apt-get upgrade ceph-ansible

To: 
From:
If upgrading from Ceph 3.x to the latest version, on the Ansible administration node, ensure the latest version of the ceph-ansible package is installed.

[root@admin ~]$ sudo apt-get install ceph-ansible

Additional info:

Can combine this change with the previous point in the upgrade guide since both will use same command. ie "sudo apt-get install ceph-ansible"

Comment 3 Ken Dreyer (Red Hat) 2018-04-04 16:18:05 UTC
What is the exact error you get when upgrading the ceph-ansible package with "apt-get upgrade"?