Bug 1563788

Summary: [RFE] Perform clean-up / maintenance on Director
Product: Red Hat OpenStack Reporter: Irina Petrova <ipetrova>
Component: rhosp-directorAssignee: Angus Thomas <athomas>
Status: CLOSED WONTFIX QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 17.0 (Wallaby)CC: aschultz, dbecker, jjoyce, jschluet, kecarter, mburns, morazi, ramishra, slinaber, tvignaud
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-01-06 21:51:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Irina Petrova 2018-04-04 17:19:13 UTC
Description of problem:

Scaling up large environments generates a lot of garbage that Director never purges/cleans up. 

For example, customers report having have to clean up:

- old journal logs (journalctl --vacuum-time=1d) --> we gained around 2Gb
- old openstack projects logs
- old puppet report files ( /var/lib/puppet/reports/) --> we gained around 10Gb
(heat-manage purge_deleted does nothing) 
 
Our recommendation is for dedicating at least 40 GB of disk space. But even with double that size, issues can occur in the long term due to running out of space (especially if it happens on upgrade/scaling operations).

Version-Release number of selected component (if applicable):
RHOS-10

Comment 1 Rabi Mishra 2018-04-05 07:26:00 UTC
heat-manage purge_deleted is specifically there for for heat db cleanup and not journal or puppet report files.