Bug 1564083

Summary: Frequent "render process crashed" errors
Product: [Fedora] Fedora Reporter: Ankur Sinha (FranciscoD) <sanjay.ankur>
Component: qutebrowserAssignee: Timothée Floure <timothee.floure>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 28CC: kevin, timothee.floure, torsava
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-04-05 15:49:38 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ankur Sinha (FranciscoD) 2018-04-05 10:32:03 UTC
Description of problem:
I'm getting "render process crashed" errors frequently in F28 now.

Version-Release number of selected component (if applicable):
qutebrowser-1.2.1-1.fc28.noarch

How reproducible:
Always

Steps to Reproduce:
1. visit web.whatsapp.com (always crashes on this one)
2.
3.

Actual results:
Crashes with "Render process crashed"

Expected results:


Additional info:
Journalctl has this in it:

Apr 05 11:19:56 ankur.pc qutebrowser.desktop[17713]: 11:19:56 ERROR: Renderer process crashed
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: Received signal 11 SEGV_MAPERR 000000000000
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: #0 0x7f9e136a0b46 <unknown>
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: #1 0x7f9e136a04b9 <unknown>
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: #2 0x7f9e136a0acc <unknown>
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: #3 0x7f9e103b7fb0 <unknown>
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: #4 0x7f9e0696cfc4 av_buffer_get_opaque
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: #5 0x7f9e124f11ab <unknown>
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: #6 0x7f9e124f12dc <unknown>
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: #7 0x7f9e124f1751 <unknown>
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: #8 0x7f9e124c08ca <unknown>
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: #9 0x7f9e124c4422 <unknown>
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: #10 0x7f9e124c4b44 <unknown>
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: #11 0x7f9e124b3c65 <unknown>
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: #12 0x7f9e13721d0b <unknown>
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: #13 0x7f9e136bc8c0 <unknown>
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: #14 0x7f9e136bcb3d <unknown>
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: #15 0x7f9e136bddee <unknown>
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: #16 0x7f9e136bf0a1 <unknown>
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: #17 0x7f9e136dc62d <unknown>
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: #18 0x7f9e136f6dbf <unknown>
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: #19 0x7f9e136f249b <unknown>
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: #20 0x7f9e103ad564 start_thread
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: #21 0x7f9e0f7a331f __GI___clone
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]:   r8: 00007f9da8014f00  r9: 0000000000000007 r10: 000000000000ac44 r11: 000000000000ac44
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]:  r12: 00007f9da8009c68 r13: 0000000000000000 r14: 00007f9db6efbe20 r15: 00007f9db6efbe10
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]:   di: 0000000000000000  si: 0000000000000002  bp: 0000000000000273  bx: 00007f9da80077e0
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]:   dx: 0000000000000002  ax: 00007f9da8008b00  cx: 0000000000000006  sp: 00007f9db6efbdc8
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]:   ip: 00007f9e0696cfc4 efl: 0000000000010202 cgf: 002b000000000033 erf: 0000000000000004
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]:  trp: 000000000000000e msk: 0000000000000000 cr2: 0000000000000000
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: [end of stack trace]
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: Calling _exit(1). Core file will not be generated.
Apr 05 11:27:16 ankur.pc qutebrowser.desktop[17713]: 11:27:16 ERROR: Renderer process crashed


There's a FAQ related to GCC 6 and qtwebengine here that speaks about render process crashes. Not sure if it's relevant, though.
https://www.qutebrowser.org/doc/faq.html

Cheers,
Ankur

Comment 1 Ankur Sinha (FranciscoD) 2018-04-05 14:11:36 UTC
Also reproducible with the Falcon browser, so possibly a qtwebengine issue.

Comment 2 Kevin Kofler 2018-04-05 15:49:38 UTC

*** This bug has been marked as a duplicate of bug 1563446 ***