Bug 1564860

Summary: ipv6.method ignore still allows link local FE80 address on interface
Product: [Fedora] Fedora Reporter: Eric Lajoie <elajoie>
Component: NetworkManagerAssignee: Lubomir Rintel <lkundrak>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 28CC: alexl, bgalvani, dcbw, fgiudici, john.j5live, lkundrak, mclasen, rhughes, rstrode, sandmann, thaller
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-04-09 20:12:28 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Eric Lajoie 2018-04-08 10:23:29 UTC
Description of problem:
When I use "nmcli connection modify enp1s0 ipv6.method ignore" I expect all IPv6 addressing to be disabled.

Version-Release number of selected component (if applicable):
nmcli tool, version 1.10.6-1.fc28


How reproducible:
Always even after reloads

Steps to Reproduce:
1.nmcli connection modify enp1s0 ipv6.method ignore
2.nmcli con sh enp1s0 | grep IP6
3.ip ad

Actual results:
Link Local FE80 address assigned

Expected results:
No IPv6 addressing (in my case on IPv4)

Additional info:

Comment 1 Thomas Haller 2018-04-08 15:54:21 UTC
There is no ipv6.method disabled. That is a missing feature. "ignore" is not the same as "disabled".

Comment 2 Eric Lajoie 2018-04-08 18:54:09 UTC
OK, I thought ipv4.method disabled was the same as ipv6.method ignore since we have an ipv4.method of link-local as well.

Thanks