Bug 1564876

Summary: Missing bootstrap.min.css
Product: [Fedora] Fedora Reporter: Jakub Kadlčík <jkadlcik>
Component: python-XStatic-Bootstrap-SCSSAssignee: Matthias Runge <mrunge>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: mrunge, rdopiera
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-04-09 06:36:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jakub Kadlčík 2018-04-08 13:05:29 UTC
Description of problem:
There is no `bootstrap.min.css` file in the package. This is a problem because the upstream documentation refers to this file. See https://getbootstrap.com/docs/3.3/getting-started/


Version-Release number of selected component (if applicable):
3.3.7.1-3.fc28


How reproducible:
Always


Steps to Reproduce:
1. rpm -ql xstatic-bootstrap-scss-common |grep "min\."


Actual results:
There is only `bootstrap.min.js`, no `bootstrap.min.css`


Expected results:
There should be also a `bootstrap.min.css` file

Comment 1 Radomir Dopieralski 2018-04-09 06:36:20 UTC
The xstatic packages should not contain minified files — those are generated by the application using them. The bootstrap.min.js is an exception, because the process of compiling it is non-trivial.

Comment 2 Jakub Kadlčík 2018-04-09 07:16:35 UTC
Thank you for the reply Radomir.
I would like to note, that there is also no `bootstrap.css` file. Should this one be generated too?

In such case, I think that it would be a good idea to explain this in README.txt and show us the way how to do it. Or if this is a case for most xstatic packages, describing it on https://fedoraproject.org/wiki/Packaging:Web_Assets

Comment 3 Jakub Kadlčík 2018-04-09 08:00:35 UTC
I also don't understand why xstatic packages should not contain minified files. Why don't we generate such files during %build phase and provide them?

Comment 4 Matthias Runge 2018-04-09 08:09:18 UTC
The python-xstatic packages were included to carry libraries required for OpenStack dashboard. bootstrap.min.js was not required, since openstack dashboard compresses js files at runtime/when required. There is often a disussion around this mine-field. For example, Debian considers minified js as non-free.

I found also https://fedoraproject.org/wiki/Packaging:JavaScript#Compilation.2FMinification 

which has no clear guideline for or against minification.

Comment 5 Radomir Dopieralski 2018-04-09 09:38:13 UTC
Jakub, can you tell us what is the actual problem you are trying to solve here? Maybe we could then suggest a better solution.

Comment 6 Jakub Kadlčík 2018-04-10 11:44:46 UTC
Thank you guys,
I am currently not trying to solve any actual problem, I just think that xstatic packages are an awesome thing and helped me to remove hundreds of files of third-party code that were bundled in the project.

The only issue of this packages, in general, is a lack of documentation. Particularly in case of `xstatic-bootstrap-scss-common` I don't even know how to use it.

Can I ask you to update the README.txt and add a few lines about how to use it?