Bug 1564900

Summary: Rebase openscap in Red Hat Enterprise Linux 7.6 to latest upstream version
Product: Red Hat Enterprise Linux 7 Reporter: Marek Haicman <mhaicman>
Component: openscapAssignee: Matěj Týč <matyc>
Status: CLOSED ERRATA QA Contact: Matus Marhefka <mmarhefk>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.4CC: jcerny, matyc, mhaicman, mpreisle, mthacker, openscap-maint
Target Milestone: rcKeywords: Rebase
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-10-30 11:44:40 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Marek Haicman 2018-04-08 18:53:19 UTC
Description of problem:
Upstream version of OpenSCAP contains lots of small fixes that would be hard to backport. OpenSCAP has good upstream test coverage, thus rebasing bears low risk.

Version currently in RHEL7 is 1.2.16 https://github.com/OpenSCAP/openscap/compare/1.2.16...maint-1.2 shows changes in upstream since then.

Comment 1 Jan Černý 2018-05-29 09:10:17 UTC
OpenSCAP 1.2.17 has been released. For more details, please see:
https://www.redhat.com/archives/open-scap-list/2018-May/msg00020.html

Link to GitHub release page:
https://github.com/OpenSCAP/openscap/releases/tag/1.2.17

Comment 6 errata-xmlrpc 2018-10-30 11:44:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3302