Bug 1565026

Summary: Ansible python3 default
Product: [Fedora] Fedora Reporter: Jan Kurik <jkurik>
Component: Changes TrackingAssignee: Kevin Fenzi <kevin>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 29CC: kevin, martin.bukatovic, s
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: ChangeAcceptedF29,SelfContainedChange
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-11-30 17:04:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jan Kurik 2018-04-09 07:47:37 UTC
This is a tracking bug for Change: Ansible python3 default 
For more details, see: https://fedoraproject.org/wiki/Changes/Ansible_python3_default

Ansible started out as a python2 only application, but in recent years a large amount of work has gone into porting things to python3. Last year, the Fedora ansible package started shipping a ansible-python3 allowing users to switch to python3 on the control host easily if they wished, but left the default as python2. Now in Fedora 29, the default will be switched and the python3 version will be the only version shipped.

Comment 1 Kevin Fenzi 2018-04-14 19:14:29 UTC
The change has already been made in rawhide.

Comment 2 Jan Kurik 2018-08-14 11:22:58 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 3 Serge Matveenko 2018-10-23 16:38:35 UTC
This looks like a premature change. I've tried to use Ansible with Python 3 and it is still not fully compatible. I'm going to repeat my tests to be sure.

Comment 4 Ben Cotton 2018-11-30 17:04:40 UTC
This Change appears to have been implemented for Fedora 29. If it is not closed, please let me know so I can re-open it against Rawhide.