Bug 1565067

Summary: Please enable the "xorg-x11-drv-libinput" and/or "xorg-x11-drv-evdev" package for s390x, too
Product: [Fedora] Fedora Reporter: Thomas Huth <thuth>
Component: xorg-x11-drv-evdevAssignee: X/OpenGL Maintenance List <xgl-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 28CC: alexl, btissoir, caillon+fedoraproject, extras-qa, jglisse, john.j5live, rhughes, rstrode, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: s390x   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1565062 Environment:
Last Closed: 2018-04-18 05:25:46 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Thomas Huth 2018-04-09 10:07:02 UTC
Please also enable the "xorg-x11-drv-evdev" for Fedora 28!

+++ This bug was initially created as a clone of Bug #1565062 +++

Description of problem:
Recent versions of QEMU provide a virtual graphic card called "virtio-gpu-ccw" and virtual input devices "virtio-keyboard-ccw" and "virtio-mouse-ccw". These can be used to supply graphical environment for KVM guests on s390x, too. Using a custom kernel that has support enabled for this, X11 also already starts fine with this graphics card in a s390x Fedora 27 guest, but the mouse and keyboard are not working there yet, since the "evdev" driver is still missing. The SPEC file of the package currently contains this line which blocks the package from being build on s390x:

ExcludeArch: s390 s390x

Please remove the line from the spec file, so that the package also gets build for s390x. I already did that locally here in my s390x F27 guest, and verified that the package then compiles fine on s390x, too. I then installed the compiled RPM and was able to use the mouse and keyboard in X11, too.

Version-Release number of selected component (if applicable):
xorg-x11-drv-evdev-2.10.5-4.fc27.s390x

How reproducible:
100%

Steps to Reproduce:
1. Install a F27 guest with a kernel that can deal with the virtio devices
   (requires CONFIG_VT, for example)
2. Start QEMU with the parameters "-device virtio-gpu-ccw -device virtio-keyboard-ccw -device virtio-mouse-ccw" to run the guest 
3. startx
4. Try to move the mouse or use the keyboard

Actual results:
Mouse and keyboard can not be used.

Expected results:
Mouse and keyboard are usable in X11

Comment 1 Thomas Huth 2018-04-09 17:53:01 UTC
xorg-x11-drv-libinput should work, too, see https://bugzilla.redhat.com/show_bug.cgi?id=1565062#c2

Comment 2 Thomas Huth 2018-04-18 05:25:46 UTC
Closing, since this has been handled in BZ 1565062 already.

*** This bug has been marked as a duplicate of bug 1565062 ***