Bug 1565812 (CVE-2018-9268)

Summary: CVE-2018-9268 wireshark: memory leak in epan/dissectors/packet-smb2.c
Product: [Other] Security Response Reporter: Laura Pardo <lpardo>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED NOTABUG QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: unspecifiedCC: denis, huzaifas, lemenkov, mruprich, msehnout, phatina, rvokal
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: wireshark 2.4.6, wireshark 2.2.14 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-05-07 18:48:07 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1565675, 1565684, 1575736    
Bug Blocks: 1565716    

Description Laura Pardo 2018-04-10 20:08:47 UTC
A flaw was found in Wireshark 2.4.0 to 2.4.5 and 2.2.0 to 2.2.13, epan/dissectors/packet-smb2.c has a memory leak.


References:
https://www.wireshark.org/security/wnpa-sec-2018-24.html
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=14483

Patch:
https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=c69d710d2bf39fe633800db65efddf55701131b6

Comment 1 Laura Pardo 2018-04-10 20:10:07 UTC
Created wireshark tracking bugs for this issue:

Affects: fedora-all [bug 1565684]