Bug 1566458

Summary: [RFE] Playbook should configure kubeletArguments once the cluster is up and running
Product: OpenShift Container Platform Reporter: Joel Rosental R. <jrosenta>
Component: RFEAssignee: Brenton Leanhardt <bleanhar>
Status: CLOSED CURRENTRELEASE QA Contact: Xiaoli Tian <xtian>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 3.7.0CC: aos-bugs, jokerman, matthias.martetschlaeger, mmccomas
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-04-18 14:54:39 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Joel Rosental R. 2018-04-12 11:07:18 UTC
1. Proposed title of this feature request
 
kubeletArguments should be configurable through ansible playbooks once cluster is up and running.


3. What is the nature and description of the request?

 As a user I would like to be able to re-adjust some parameters in OCP nodes configuration such as kubeletArguments once the cluster is up and running through ansible playbooks since although it's possible to do it before installing OCP through the openshift_node_kubelet_args in the inventory file, it seems that once the cluster is installed when /usr/share/ansible/openshift-ansible/playbooks/byo/config.yml is run again it does not modify /etc/origin/node/node-config.yaml 


5. How would the customer like to achieve this? (List the functional requirements here)

  Through an ansible-playbook that allows these types of changes, since doing them manually it's error prone.


6. For each functional requirement listed in question 5, specify how Red Hat
and the customer can test to confirm the requirement is successfully implemented.
  
  Through an ansible-playbook that allows these types of changes


7. Is there already an existing RFE upstream or in Red Hat bugzilla?
 No

 
10. List any affected packages or components.
  atomic-openshift-utils

Comment 3 Scott Dodson 2019-04-18 14:54:39 UTC
This was delivered in 3.10 where you configure configmaps in the openshift-node group and those changes are then rolled out automatically to nodes in that group.