Bug 1566566

Summary: The Fedora 28 KDE Live background wallpaper image is old (from Fedora 27)
Product: [Fedora] Fedora Reporter: Lukas Ruzicka <lruzicka>
Component: kde-settingsAssignee: Rex Dieter <rdieter>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 28CC: awilliam, fzatlouk, jgrulich, jreznik, lruzicka, mbriza, me, rdieter, robatino, smparrish, than
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedBlocker
Fixed In Version: kde-settings-28.0-1.fc28 kde-settings-28.0-2.fc28 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-04-17 00:21:07 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1469206    

Description Lukas Ruzicka 2018-04-12 14:17:40 UTC
Description of problem:

The default background wallpaper image for Fedora 28 KDE Live is the same as it was in Fedora 27. This does not comply with the release criteria "The default desktop background must be different from that of the last two stable releases.)" for Fedora and thus is a blocker.

Version-Release number of selected component (if applicable):

In the system, I can see the following packages:

f27-backgrounds-base-27.0.1-3.fc28.noarch
f27-backgrounds-kde-27.0.1-3.fc28.noarch
f28-backgrounds-base-28.1.0-1.fc28.noarch

How reproducible:

Always

Steps to Reproduce:
1. Run the Fedora 28 KDE Live

Actual results:

The desktop wallpaper image is the same as it was in the previous release.

Expected results:

The desktop wallpaper image should be the same as in the Fedora Workstation 28.

Additional info:

The f27-backgrounds-kde has the following dependencies in the system, so it may be advocated that it is needed, but it seems like f28-backgrounds-kde should be also installed at least, or the f27-backgrounds packages should be changed to f28-backgrounds packages. Those packages are built in Koji.

 kde-print-manager            x86_64    17.12.3-1.fc28    @anaconda    1.7 M
 kde-print-manager-libs       x86_64    17.12.3-1.fc28    @anaconda    541 k
 kde-settings-plasma          noarch    27-1.fc28.3       @anaconda    7.0 k
 plasma-desktop               x86_64    5.12.4-1.fc28     @anaconda     28 M
 plasma-integration           x86_64    5.12.4-1.fc28     @anaconda    487 k
 plasma-lookandfeel-fedora    noarch    5.12.4-1.fc28     @anaconda     10 M
 plasma-workspace             x86_64    5.12.4-1.fc28     @anaconda     19 M
 plasma-workspace-libs        x86_64    5.12.4-1.fc28     @anaconda    5.8 M
 sddm-breeze                  noarch    5.12.4-1.fc28     @anaconda    414 k
 xorg-x11-apps                x86_64    7.7-20.fc28       @anaconda    938 k

Comment 1 Fedora Blocker Bugs Application 2018-04-12 14:21:31 UTC
Proposed as a Blocker for 28-final by Fedora user lruzicka using the blocker tracking app because:

 This bug breaks the release criteria for Fedora 28, because the desktop wallpaper image does not differ from the previous ones.

Comment 2 Lukas Ruzicka 2018-04-12 14:23:54 UTC
Updated info:

The KDM wallpaper (the login screen) is fine.

Comment 3 Adam Williamson 2018-04-12 21:31:58 UTC
It's SDDM, not KDM.

That's odd, thought I'd checked this a while back and it was right. But looking at openQA for today, indeed, the KDE desktop background is still the F27 one...

Looks like the package that needs to be updated here is kde-settings, and it *has* been, but not sent to Bodhi:

https://koji.fedoraproject.org/koji/buildinfo?buildID=1057557

Comment 4 Fedora Update System 2018-04-13 13:18:26 UTC
kde-settings-28.0-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-f9fd8257b0

Comment 5 Fedora Update System 2018-04-15 02:26:03 UTC
kde-settings-28.0-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-f9fd8257b0

Comment 6 František Zatloukal 2018-04-16 14:39:00 UTC
Issue is fixed in kde-settings-28.0-2.fc28 .

Comment 7 František Zatloukal 2018-04-16 16:56:19 UTC
Discussed during the 2018-04-16 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made as it violates the following blocker criteria:

"The default desktop background must be different from that of the last two stable releases"

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-04-16/f28-blocker-review.2018-04-16-16.00.log.txt

Comment 8 Fedora Update System 2018-04-17 00:21:07 UTC
kde-settings-28.0-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.