Bug 1566666

Summary: VirtualGL version 2.5.3?
Product: [Fedora] Fedora Reporter: JM <igeorgex>
Component: VirtualGLAssignee: Gary Gatling <gsgatlin>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 27CC: enrico.tagliavini, gsgatlin
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: VirtualGL-2.5.2-1.fc27 VirtualGL-2.5.2-1.fc28 VirtualGL-2.5.2-1.el6 VirtualGL-2.5.2-1.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-07 11:49:40 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description JM 2018-04-12 18:06:12 UTC
The Fedora version of VirtualGL ist 2.4 which has several bugs, the stable version of VirtualGL is 2.5.3 (https://github.com/VirtualGL/virtualgl/blob/master/ChangeLog.md).  Is there a chance that the Fedora RPM will get an update to version 2.5.x?

Comment 1 Gary Gatling 2018-04-12 18:07:40 UTC
I'll try to see if I can figure out how to package the newer version.

Comment 2 JM 2018-04-12 18:10:45 UTC
That would be great!

Comment 3 Gary Gatling 2018-05-02 13:59:06 UTC
I see a 2.5.2 in https://sourceforge.net/projects/virtualgl/files/ but I did not see a 2.5.3.

Currently trying to build his 2.5.2 rpm. I am making edits to add various BuildRequires: lines at this point to try to get it to compile in fedora 28.

Comment 4 Gary Gatling 2018-05-09 18:14:39 UTC
I have sent an email to legal@lists.fedoraproject.org asking if the change of license from "wxWidgets" to "wxWindows Library License v3.1" in the new version is permitted to be in fedora/EPEL. I have something that builds now but more tests need to be done with vglconnect / vglrun before submitting it as an update.

Comment 5 JM 2018-05-09 18:55:16 UTC
You're right, it looks like version 2.5.2 is the stable version. And thank you for all your efforts.

Comment 6 Gary Gatling 2018-05-09 20:54:34 UTC
My tests indicate its working good with fedora 28 client and fedora 28 server. You have to remember to open port 4242/tcp with firewall-cmd for it to work.

I will test from fedora 28 to RHEL 6/7 and RHEL 6/7 to fedora 28 when I get back from a trip I have to take up to D.C. over the next few days.

Comment 7 Fedora Update System 2018-05-29 15:28:45 UTC
VirtualGL-2.5.2-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-6e1094319a

Comment 8 Fedora Update System 2018-05-29 15:46:01 UTC
VirtualGL-2.5.2-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-de5c029de5

Comment 9 Fedora Update System 2018-05-29 15:57:37 UTC
VirtualGL-2.5.2-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-ab5f6eedc5

Comment 10 Fedora Update System 2018-05-29 16:03:28 UTC
VirtualGL-2.5.2-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-03c630c551

Comment 11 Fedora Update System 2018-05-30 13:41:38 UTC
VirtualGL-2.5.2-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-de5c029de5

Comment 12 Fedora Update System 2018-05-30 15:02:12 UTC
VirtualGL-2.5.2-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-ab5f6eedc5

Comment 13 Fedora Update System 2018-05-30 15:10:08 UTC
VirtualGL-2.5.2-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-03c630c551

Comment 14 Fedora Update System 2018-05-30 16:55:33 UTC
VirtualGL-2.5.2-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-6e1094319a

Comment 15 Fedora Update System 2018-06-07 11:49:40 UTC
VirtualGL-2.5.2-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2018-06-07 12:34:54 UTC
VirtualGL-2.5.2-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2018-06-14 17:42:44 UTC
VirtualGL-2.5.2-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2018-06-14 19:52:23 UTC
VirtualGL-2.5.2-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.