Bug 1566762

Summary: Fontconfig error: "/etc/fonts/fonts.conf", line 6: invalid attribute 'translate'...
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: chromiumAssignee: Tom "spot" Callaway <tcallawa>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 28CC: ajax, alexl, fonts-bugs, i18n-bugs, john.j5live, mclasen, rhughes, rstrode, sandmann, tagoh, tcallawa, yaneti
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: chromium-65.0.3325.181-3.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-04-10 03:36:17 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Miro Hrončok 2018-04-12 23:33:03 UTC
Description of problem:
When I upgraded to Fedora 28, this was in the scriptlet logs:
Fontconfig error: Cannot load config file from /etc/fonts/fonts.conf
Fontconfig error: "/etc/fonts/conf.d/10-hinting-slight.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/10-hinting-slight.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/10-hinting-slight.conf", line 6: invalid attribute 'version'
Fontconfig error: "/etc/fonts/conf.d/10-hinting-slight.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 6: invalid attribute 'version'
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 6: invalid attribute 'xmlns:its'
... snip (a lot more)

It appears now and then, for example with jupyter notebook

Version-Release number of selected component (if applicable):
fontconfig-2.13.0-3.fc28


How reproducible: easy (but there mind be an easier way)


Steps to Reproduce:
1. $ sudo dnf install python3-notebook
2. $ python3 -m notebook

Actual results: the above warnings and errors are in the output in terminal


Expected results: no warnings, no errors

Comment 1 Akira TAGOH 2018-04-17 12:24:54 UTC
I can't reproduce that. well, that's likely to happen only when you are running something with older library with new config. guess you use chrome as your default browser? I suppose chrome has own fontconfig in their runtime. in that case there are nothing I can do.

Comment 2 Miro Hrončok 2018-04-17 14:08:51 UTC
I use chromium from Fedora. Right, the messages are from the browser and not the notebook, sorry.

Comment 3 Tom "spot" Callaway 2018-04-17 21:05:41 UTC
Chromium uses fontconfig 2.12.6, we're on fontconfig 2.13.0.

I think I can safely use the system fontconfig in current chromium, this should resolve the issue. I have a build with that config going in rawhide now.

Comment 4 Parag Nemade 2019-04-10 03:36:17 UTC
I believe this is fixed already if not reopen it.
See https://src.fedoraproject.org/rpms/chromium/c/e00e15df7ee56234e38d6db3d6178b65aa22f937?branch=master