Bug 1568273

Summary: Nagios service disabled after each update
Product: [Fedora] Fedora EPEL Reporter: Jan ONDREJ <ondrejj>
Component: nagiosAssignee: Stephen John Smoogen <smooge>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: epel7CC: affix, athmanem, b.heden, herrold, jose.p.oliveira.oss, lemenkov, linux, shawn.starr, smooge, smooge, s, swilkerson
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: nagios-4.4.3-1.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-12-03 19:57:12 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jan ONDREJ 2018-04-17 06:09:53 UTC
Description of problem:
After each update nagios service is always disabled, even if it was enabled by admin previously.

Version-Release number of selected component (if applicable):
nagios-4.3.4-5.el7.x86_64
I think previous versions too.

How reproducible:
always

Steps to Reproduce:
1. systemctl is-enabled nagios.service
2. yum reinstall nagios -y
3. systemctl is-enabled nagios.service

Actual results:
enabled
disabled

Expected results:
enabled
enabled

Additional info:
Looks like this postinstall script causes this problem:

/usr/bin/systemctl --no-reload preset nagios.service  > /dev/null 2>&1 || :

Why this is good for?
May be you want something like in other services, for example:

if [ $1 -eq 1 ] ; then 
        # Initial installation 
        systemctl preset nagios.service >/dev/null 2>&1 || : 
fi

Please, fix this before you release a new update.

Comment 1 Stephen John Smoogen 2018-07-24 23:43:48 UTC
Fix should appear in next build

Comment 2 Fedora Update System 2018-07-25 00:52:30 UTC
nagios-4.3.4-13.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-41e9ecf98a

Comment 3 Fedora Update System 2018-07-25 19:52:16 UTC
nagios-4.3.4-13.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-41e9ecf98a

Comment 4 Fedora Update System 2018-07-26 11:49:50 UTC
nagios-4.3.4-13.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-41e9ecf98a

Comment 5 Fedora Update System 2018-11-30 19:58:42 UTC
nagios-4.4.2-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-0346a55d0f

Comment 6 Fedora Update System 2018-12-01 01:55:18 UTC
nagios-4.4.2-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-0346a55d0f

Comment 7 Stephen John Smoogen 2018-12-03 19:57:12 UTC

*** This bug has been marked as a duplicate of bug 1517925 ***

Comment 8 Fedora Update System 2019-01-17 00:14:49 UTC
nagios-4.4.3-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-d661b588d2

Comment 9 Fedora Update System 2019-01-18 01:00:31 UTC
nagios-4.4.3-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-d661b588d2

Comment 10 Fedora Update System 2019-02-02 00:39:28 UTC
nagios-4.4.3-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.