Bug 1568355

Summary: OSP10: Support for dpdkvhostuserclient mode
Product: Red Hat OpenStack Reporter: Saravanan KR <skramaja>
Component: puppet-tripleoAssignee: RHOS Maint <rhos-maint>
Status: CLOSED ERRATA QA Contact: Yariv <yrachman>
Severity: high Docs Contact:
Priority: high    
Version: 10.0 (Newton)CC: amuller, aschultz, atelang, augol, chrisw, fbaudin, jjoyce, jraju, jschluet, mbabushk, nyechiel, samccann, slinaber, srevivo, tfreger, tvignaud, vchundur
Target Milestone: asyncKeywords: TestOnly, Triaged, ZStream
Target Release: 10.0 (Newton)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: puppet-tripleo-5.6.8-2.el7ost Doc Type: Enhancement
Doc Text:
The dpdkvhostuserclient mode support has been backported. This feature allows OVS to connect to the vhost socket as a client, which allows for reconnecting to the socket without restarting the VM (if OVS crashes or restarts). NOTE: * All VMs should be migrated to dpdkvhostuserclient mode * Live Migration does not work for the existing VM, use either snapshot and create or cold-migration to move to dpdkvhostuserclient mode. * Add/Modify the parameter NeutronVhostuserSocketDir to "/var/lib/vhost_sockets". * Also for a new installation, remove the "set_ovs_config" section in the sample first-boot script[1]. * Add the additional environment file environments/ovs-dpdk-permissions.yaml for OVS-DPDK deployments (for new installations and minor updates). * All these validations are done with OVS version 2.9. [1] https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/10/html-single/network_functions_virtualization_configuration_guide/index#ap-ovsdpdk-first-boot
Story Points: ---
Clone Of: 1557850 Environment:
Last Closed: 2018-06-27 23:30:46 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1557850, 1568356, 1572510    
Bug Blocks: 1561869, 1561870    

Comment 8 errata-xmlrpc 2018-06-27 23:30:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2101