Bug 1568743

Summary: Debug log generation fails because the tar command is missing one of `-Acdtrux'
Product: Red Hat OpenStack Reporter: Udi <ukalifon>
Component: openstack-tripleo-commonAssignee: Honza Pokorny <hpokorny>
Status: CLOSED ERRATA QA Contact: Udi <ukalifon>
Severity: urgent Docs Contact:
Priority: high    
Version: 13.0 (Queens)CC: apannu, aschultz, beth.white, hpokorny, jjoyce, jpichon, jschluet, mburns, slinaber, tvignaud
Target Milestone: betaKeywords: Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-common-8.6.1-6.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:52:00 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1513453    

Description Udi 2018-04-18 08:23:59 UTC
Description of problem:
Try to download the debug log from the GUI. This is the error message that is displayed:

Error while creating a tarball: Unexpected error while running command. Command: /usr/bin/tar -C /tmp/tmpzAuR9S 3600 /tmp/tmpp47N2Z --exclude .git --exclude .tox --exclude *.pyc --exclude *.pyo . Exit code: 2 Stdout: u'' Stderr: u"/usr/bin/tar: You must specify one of the `-Acdtrux' or `--test-label' options\nTry `/usr/bin/tar --help' or `/usr/bin/tar --usage' for more information.\n"


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-8.3.1-2.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Download the debug log


Actual results:
Log is not generated

Comment 5 Honza Pokorny 2018-04-30 14:16:12 UTC
Backport to queens has been merged

Comment 10 Udi 2018-05-09 15:09:57 UTC
Verified: openstack-tripleo-common-8.6.1-6.el7ost.noarch

Comment 12 errata-xmlrpc 2018-06-27 13:52:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086