Bug 1569098

Summary: Placement API returning an error response: Inventory in use
Product: Red Hat OpenStack Reporter: Pavel Sedlák <psedlak>
Component: openstack-novaAssignee: Lee Yarwood <lyarwood>
Status: CLOSED ERRATA QA Contact: nova-maint
Severity: low Docs Contact:
Priority: low    
Version: 13.0 (Queens)CC: awaugama, berrange, dasmith, eglynn, jhakimra, jschluet, kchamart, lyarwood, sbauza, sferdjao, sgordon, srevivo, vromanso
Target Milestone: betaKeywords: Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-nova-17.0.3-0.20180417162852.991c292.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:52:00 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Pavel Sedlák 2018-04-18 15:33:51 UTC
Repeated "Placement API returning an error response: Inventory for '...' in use." appears in nova-placement-api.log.

It was easily confused as possible issue for ospd deployment timing out on provisioning.

Already known as https://bugs.launchpad.net/nova/+bug/1751472, backport needed.

Expected would be to not have log full of 'placement api returning error response' (>500 occurencies with 3 node setup).

> 2018-04-16 15:04:41.546 13822 INFO nova.api.openstack.placement.requestlog [req-f7b36ab7-994b-40dc-8700-2ba466168656 053d187961d14e0db78b7b3c4bca29e3 a4df037075734a8f84fea4228bccefaf - default default] 192.168.24.1 "GET /placement/resource_providers/7af6c15b-12c7-4502-bcca-264a5bdf2d6d/inventories" status: 200 len: 512 microversion: 1.0
> 2018-04-16 15:04:41.551 13821 DEBUG nova.api.openstack.placement.requestlog [req-32745f6a-fd9a-4598-bbc0-0fb90070177b 053d187961d14e0db78b7b3c4bca29e3 a4df037075734a8f84fea4228bccefaf - default default] Starting request: 192.168.24.1 "DELETE /placement/resource_providers/7af6c15b-12c7-4502-bcca-264a5bdf2d6d/inventories" __call__ /usr/lib/python2.7/site-packages/nova/api/openstack/placement/requestlog.py:38
> 2018-04-16 15:04:41.559 13821 DEBUG nova.api.openstack.placement.wsgi_wrapper [req-32745f6a-fd9a-4598-bbc0-0fb90070177b 053d187961d14e0db78b7b3c4bca29e3 a4df037075734a8f84fea4228bccefaf - default default] Placement API returning an error response: Inventory for 'VCPU, MEMORY_MB, DISK_GB' on resource provider '7af6c15b-12c7-4502-bcca-264a5bdf2d6d' in use. call_func /usr/lib/python2.7/site-packages/nova/api/openstack/placement/wsgi_wrapper.py:31

Comment 1 Pavel Sedlák 2018-04-18 19:36:10 UTC
Forgot to mention versions of packages :

openstack-nova-placement-api-17.0.3-0.20180410202744.29c9ab8.el7ost.noarch

openstack-nova-api-17.0.3-0.20180410202744.29c9ab8.el7ost.noarch
openstack-nova-common-17.0.3-0.20180410202744.29c9ab8.el7ost.noarch
openstack-nova-compute-17.0.3-0.20180410202744.29c9ab8.el7ost.noarch
openstack-nova-conductor-17.0.3-0.20180410202744.29c9ab8.el7ost.noarch
openstack-nova-scheduler-17.0.3-0.20180410202744.29c9ab8.el7ost.noarch
puppet-nova-12.4.0-0.20180329041152.9cf4dc7.el7ost.noarch
python-nova-17.0.3-0.20180410202744.29c9ab8.el7ost.noarch
python-novaclient-9.1.1-1.el7ost.noarch

Comment 9 errata-xmlrpc 2018-06-27 13:52:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086