Bug 1569150

Summary: rpminfo, rpmverify and rpmverifyfile probes do not fully support offline mode [rhel-7.5.z]
Product: Red Hat Enterprise Linux 7 Reporter: Oneata Mircea Teodor <toneata>
Component: openscapAssignee: Martin Preisler <mpreisle>
Status: CLOSED ERRATA QA Contact: Marek Haicman <mhaicman>
Severity: medium Docs Contact: Mirek Jahoda <mjahoda>
Priority: high    
Version: 7.5CC: jcerny, mhaicman, mjahoda, mmarhefk, mpreisle, mthacker, openscap-maint, toneata
Target Milestone: rcKeywords: Reopened, ZStream
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Prior to this update, the rpminfo, rpmverify, rpmverifyfile, and rpmverifypackage probes did not fully support offline mode. Consequently, OpenSCAP RPM verification rules did not work correctly when scanning virtual machine (VM) and container file systems in offline mode. With this update, the previous removal of the chroot() function in the offline scan in rpm probes has been reverted and offline mode in those probes has been fixed. Results of scanning VM and container file systems in offline mode no longer contain false negatives.
Story Points: ---
Clone Of: 1556988 Environment:
Last Closed: 2018-05-14 16:13:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1556988    
Bug Blocks:    

Description Oneata Mircea Teodor 2018-04-18 17:12:25 UTC
This bug has been copied from bug #1556988 and has been proposed to be backported to 7.5 z-stream (EUS).

Comment 7 errata-xmlrpc 2018-05-14 16:13:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1405