Bug 1569249

Summary: [Docs][Planning] New minimum disk size for RHV-H since 4.1.4
Product: Red Hat Enterprise Virtualization Manager Reporter: Andrea Perotti <aperotti>
Component: DocumentationAssignee: Tahlia Richardson <trichard>
Status: CLOSED CURRENTRELEASE QA Contact: Byron Gravenorst <bgraveno>
Severity: high Docs Contact:
Priority: high    
Version: 4.1.9CC: bgraveno, lbopf, lsurette, rbalakri, rbarry, srevivo, ykaul
Target Milestone: ovirt-4.2.4Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: docs-accepted
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-14 04:09:58 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Docs RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Andrea Perotti 2018-04-18 21:42:36 UTC
Description of problem:
As tracked in #1497062 35Gb is not enough to install RHV-H with default partitioning not due to the increase of our minimum partition size requirement but due to anaconda addressing LVM thin pool best practices.

Would be good to update this section:
https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.1/html/planning_and_prerequisites_guide/requirements#storage_requirements

declaring that the minimum disk size for RHV is 45G

Up to RHVH mgmt decide how much in detail going into.

This note could be helpful, but we need to be extremely precise with the math then:
"Anaconda reserves 20% of the thin pool size within the volume group for future metadata expansion. This is to prevent an out-of-the-box configuration from running out of space under normal usage conditions. Overprovisioning of thin pools during installation is also not supported" 

from: https://bugzilla.redhat.com/show_bug.cgi?id=1497062#c16

Comment 1 Lucy Bopf 2018-05-03 01:01:33 UTC
Ryan, can you take a look at this request and confirm the changes we should apply to the documentation to address this issue? (Particularly "Up to RHVH mgmt decide how much in detail going into.")

Comment 2 Ryan Barry 2018-05-03 01:15:48 UTC
Well, I'm not mgmt ;) But Andrea's comment looks pretty much perfect to me. Especially since we don't have a firm answer as to why this changed in 7.4 yet -- the Anaconda team is investigating

Comment 3 Lucy Bopf 2018-05-24 04:13:29 UTC
Accepting into 4.2.4 (z1) program and assigning to Tahlia for review.

Tahlia, I think this should be fixed in both 4.1 and 4.2, because it affects installations.

Comment 4 Tahlia Richardson 2018-06-06 06:46:38 UTC
Ryan, the table in https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.1/html/planning_and_prerequisites_guide/requirements#storage_requirements contains a table of directories and sizes adding up to the total minimum size. Which items need to be increased (or added?) to raise the total to 45?

Comment 5 Ryan Barry 2018-06-06 13:21:06 UTC
There were no changes or increases here.

Instead, a change in Anaconda during 7.4 resulted in 20% overhead (approximately) being added to all thin LVs to account for LV metadata growth