Bug 1569372

Summary: Hosted engine deployment is halting at VM Shutdown
Product: [oVirt] ovirt-hosted-engine-setup Reporter: Nicolas Rigaud <nicolas.rigaud>
Component: GeneralAssignee: Ido Rosenzwig <irosenzw>
Status: CLOSED DUPLICATE QA Contact: meital avital <mavital>
Severity: high Docs Contact:
Priority: unspecified    
Version: 2.2.16CC: bugs, dfediuck, nicolas.rigaud, stirabos
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-04-20 09:27:08 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Integration RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
ovirt hosted engine setup log none

Description Nicolas Rigaud 2018-04-19 07:31:53 UTC
Created attachment 1423934 [details]
ovirt hosted engine setup log

Description of problem:
Hosted engine deployment is halting at VM Shutdown.

The deployment ends with the following error:
[ INFO ] TASK [Wait for local VM shutdown]
[ ERROR ] fatal: [localhost]: FAILED! => {"attempts": 120, "changed": true, "cmd": ["virsh", "-r", "domstate", "HostedEngineLocal"], "delta": "0:00:00.031405", "end": "2018-04-19 09:00:29.698977", "rc": 0, "start": "2018-04-19 09:00:29.667572", "stderr": "", "stderr_lines": [], "stdout": "fermé", "stdout_lines": ["fermé"]}




How reproducible:



Steps to Reproduce:
1.install ovirt node
2.launch cockpit and choose Deploy oVirt hosted engine on storage that has already been provisioned
3.the deployment fails at step 5 (Finish)

Actual results:
Hosted engine deployment is failing


Expected results:
The deployment process should detect that the VM is shut off

Additional info:
The version i have is using dominfo to check the status of the VM, i also tried to replace dominfo with domstate (as specified here: https://github.com/oVirt/ovirt-hosted-engine-setup/commit/305ce334c277bc6c83db418f7c200be06f9827a4) but i have the same result.

During the process, i manually checked the vm status with virsh -r dominfo and also with domstate, in both cases i have an output telling "shut off".


Version-Release number of selected component (if applicable):
Ovirt-node deployed with ovirt-node-ng-installer-ovirt-4.2-2018041606.iso

Comment 1 Doron Fediuck 2018-04-20 09:01:38 UTC
This "fermé" suggest you are using a French locale and our code is missing the end sequence.

Can you please confirm which locale you are using?

Comment 2 Nicolas Rigaud 2018-04-20 09:17:32 UTC
I was also surprised by this "fermé". However when i installed Ovirt Node, i let the default language to US English but i choosed to use a French Keyboard.

If i send the "locale" command i have the following output:

LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

I don't understand where this "fermé" comes from.

If i manually do the command i see "shut off":
virsh -r domstate HostedEngineLocal
shut off

Thanks!

Comment 3 Simone Tiraboschi 2018-04-20 09:27:08 UTC
(In reply to Nicolas Rigaud from comment #2)
> I don't understand where this "fermé" comes from.

It seams it comes from the browser language trough cockpit

*** This bug has been marked as a duplicate of bug 1566162 ***