Bug 1570522

Summary: Bond and slaves status are wrong when one of the slaves has the host connection [rhel-7.5.z]
Product: Red Hat Enterprise Linux 7 Reporter: Oneata Mircea Teodor <toneata>
Component: NetworkManagerAssignee: sushil kulkarni <sukulkar>
Status: CLOSED ERRATA QA Contact: Desktop QE <desktop-qa-list>
Severity: high Docs Contact: Ioanna Gkioka <igkioka>
Priority: high    
Version: 7.5CC: aloughla, atragler, bgalvani, cshao, danken, dougsland, fgiudici, huzhao, igkioka, lrintel, mburman, mpitt, mtessun, mvollmer, phoracek, qiyuan, rbarry, rkhan, sbonazzo, sukulkar, thaller, toneata, vbenes, weiwang, yaniwang, ycui, yturgema, yzhao
Target Milestone: rcKeywords: Regression, ZStream
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: NetworkManager-1.10.2-14.el7_5 Doc Type: Bug Fix
Doc Text:
Due to a bug, NetworkManager did not correctly connect all slaves when the master connection was activated and the autoconnect-slaves option was set. This bug has been fixed, and slaves connections now are always activated if autoconnect-slaves is set.
Story Points: ---
Clone Of: 1548265 Environment:
Last Closed: 2018-05-14 16:13:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1548265    
Bug Blocks:    

Description Oneata Mircea Teodor 2018-04-23 06:57:00 UTC
This bug has been copied from bug #1548265 and has been proposed to be backported to 7.5 z-stream (EUS).

Comment 4 Vladimir Benes 2018-04-27 13:07:39 UTC
both tests:
bridge_autoconnect_slaves_all_modified
bridge_autoconnect_slaves_all

passed on all architectures

Comment 7 errata-xmlrpc 2018-05-14 16:13:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1406