Bug 1571336

Summary: %forgemeta macro not available in Copr
Product: [Community] Copr Reporter: Peter Oliver <mavit>
Component: backendAssignee: clime
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: low Docs Contact:
Priority: unspecified    
Version: unspecifiedCC: clime, praiskup
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-04-25 11:17:47 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Peter Oliver 2018-04-24 14:31:50 UTC
The version of redhat-rpm-config currently in Fedora 27 includes some new convenience macros to make it easier to package projects hosted in Git repositories.  See https://fedoraproject.org/wiki/Forge-hosted_projects_packaging_automation for details.

If I try to build such a package in Copr, I get the following error:
    stderr: error: line 3: Unknown tag: %forgemeta

I guess the builders will need updating to allow this feature to be used.

Comment 1 clime 2018-04-25 11:17:47 UTC
Hello Peter,

I have updated the builder images and they now should contain the latest redhat-rpm-config package. It will take some time though until you get a new upgraded builder allocated because they will be now slowly replacing the previous old builders (I would like to avoid killing the current builders at the moment). If you are lucky, you can get a new builder even now but I would recommend waiting just a few hours.