Bug 1571438

Summary: "subscription-manager list" shows Ceph OSD after updating overcloud compute nodes
Product: Red Hat OpenStack Reporter: Alan Bishop <abishop>
Component: openstack-tripleo-heat-templatesAssignee: Alan Bishop <abishop>
Status: CLOSED ERRATA QA Contact: Yogev Rabl <yrabl>
Severity: high Docs Contact:
Priority: high    
Version: 10.0 (Newton)CC: abishop, agurenko, ahecox, aschultz, athomas, bcourt, bkearney, csnyder, cylopez, dbecker, emacchi, gfidente, hfukumot, jdurgin, joboyer, jschluet, lhh, mburns, morazi, nbarcet, nlevine, pgrist, rhel-osp-director-maint, rhos-flags, samccann, scohen, srevivo, yrabl
Target Milestone: asyncKeywords: Triaged, ZStream
Target Release: 10.0 (Newton)   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: openstack-tripleo-heat-templates-5.3.10-2.el7ost Doc Type: Bug Fix
Doc Text:
When removing the ceph-osd RPM from overcloud nodes that do not require the package, the corresponding Ceph OSD product key was not removed. The subscription-manager would incorrectly report the Ceph OSD product was still installed. The script that handles removing the ceph-osd RPM now also removes the Ceph OSD product key. Note: The script that removes the RPM and product key executes only during the overcloud update procedure. In other words, the product key is removed only when the overcloud node is updated. After removing the ceph-osd RPM, the subscription-manager no longer reports the Ceph OSD product is installed.
Story Points: ---
Clone Of: 1571436
: 1571439 (view as bug list) Environment:
Last Closed: 2018-06-27 23:30:46 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1571436    
Bug Blocks: 1571439    

Description Alan Bishop 2018-04-24 19:24:46 UTC
+++ This bug was initially created as a clone of Bug #1571436 +++

+++ This bug was initially created as a clone of Bug #1571435 +++

+++ This bug was initially created as a clone of Bug #1500594 +++

After deploying overcloud compute nodes, "subscription-manager list" shows following message.
It indicates absence of a license for Ceph OSD.

=======================================================================
# subscription-manager list
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

Product Name:   Red Hat Enterprise Linux Server
Product Name:   Red Hat Enterprise Linux High Availability (for RHEL Server)
Product ID:     83
Version:        7.1
Arch:           x86_64
Status:         Subscribed
Status Details:
Starts:         03/03/17
Ends:           03/03/18

Product Name:   Red Hat Ceph Storage OSD
Product ID:     288
Version:        2.0
Arch:           x86_64
Status:         Not Subscribed
Status Details: Not supported by a valid subscription.
Starts:
Ends:
=======================================================================

But as you know, there is no need to subscribe Ceph OSD on compute nodes.

We think this is a side effect that director deploys same image for all nodes.
So there is ceph-osd package nevertheless whether the nodes actually need it or not.

Therefore, customer removed ceph-osd package from the node and remove
/etc/pki/product/288.pem file.
After that, "subscription-manager list" does not inform Ceph OSD.

1. Does it a software bug?
   If so, please fix this issue. I think unnecessary packages and pem file should
   be removed automatically during the installation process.

2. Please provide how to fix this issue by hand, publish it as a solution article.

--- Additional comment from Hideshi Fukumoto on 2017-10-11 22:21:14 EDT ---

Additional information:

Customer noticed that there is same problem on OSD nodes.
He thinks OSD nodes should be available with only Ceph license.
But subscription-manager shows lack of "Red Hat Enterprise Linux High Availability" license such as follows.

-------------------------------------------------------------------------------------
Product Name:	Red Hat Enterprise Linux High Availability (for RHEL Server) (★)
Product ID:     83
Version:        7.1
Arch:           x86_64
Status:         Not Subscribed
Status Details: Not supported by a valid subscription.
Starts:
Ends:

Product Name:   Red Hat Ceph Storage OSD
Product ID:     288
Version:        2.0
Arch:           x86_64
Status:         Subscribed
Status Details:
Starts:		08/22/17
Ends:           08/22/18

Product Name:   Red Hat Enterprise Linux Server
Product ID:     69
Version:        7.3
Arch:           x86_64
Status:         Subscribed
Status Details:
Starts:		08/22/17
Ends:           08/22/18

Product Name:   Red Hat Ceph Storage MON
Product ID:     286
Version:        2.0
Arch:           x86_64
Status:         Subscribed
Status Details:
Starts:		08/22/17
Ends:           08/22/18
--------------------------------------------------------------------------------------------------------

He thinks the problem undering controller/compute and ceph is same.
Director deploys all packages for all role nodes without considering subscription is not same
between OpenStack nodes and Ceph OSD nodes.

Comment 3 Yogev Rabl 2018-06-21 16:15:24 UTC
Verified

Comment 5 errata-xmlrpc 2018-06-27 23:30:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2101