Bug 1571740

Summary: Inspection fails if root device hint case doesn't match
Product: Red Hat OpenStack Reporter: Derek Higgins <derekh>
Component: openstack-ironic-inspectorAssignee: Derek Higgins <derekh>
Status: CLOSED ERRATA QA Contact: bjacot
Severity: low Docs Contact:
Priority: low    
Version: 10.0 (Newton)CC: bfournie, bjacot, mburns, sasha, slinaber
Target Milestone: ---Keywords: Triaged, ZStream
Target Release: 10.0 (Newton)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-ironic-inspector-4.2.2-5.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-01-16 17:10:59 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Derek Higgins 2018-04-25 10:46:50 UTC
Setting a root device hint on a node before introspection causes it to fail if the case doesn't match

[cloud-user@undercloud-rhel ~]$ openstack baremetal node set baremetal-0 --property root_device='{"name": "/dev/VDA"}'

[cloud-user@undercloud-rhel ~]$ openstack baremetal introspection start --wait baremetal-0
Waiting for introspection to finish...
+-------------+--------------------------------------+
| UUID        | Error                                |
+-------------+--------------------------------------+
| baremetal-0 | No disks satisfied root device hints |
+-------------+--------------------------------------+


We've removed this case sensitivity from ironic-python-agent, root hints are case insensitive during deploy, we should do the same during introspection.

Comment 1 Derek Higgins 2018-04-25 10:47:22 UTC
 This would be a rhos-10 only update as device-hint matching was switched to use ironic-lib in rhos-11

Comment 10 bjacot 2018-12-04 15:36:48 UTC
Verified in OSP10 puddle 2018-11-27.1

was able to set the properties for the root device and introspect the nodes.

[stack@undercloud-0 ~]$ rpm -qa | grep openstack-ironic-inspector
openstack-ironic-inspector-4.2.2-5.el7ost.noarch

[stack@undercloud-0 ~]$ openstack baremetal node set compute-0 --property root_device='{"name": "/dev/VDA"}'
[stack@undercloud-0 ~]$ openstack baremetal node set controller-0 --property root_device='{"name": "/dev/VDA"}'

[stack@undercloud-0 ~]$ openstack baremetal node show aa13e78d-d316-47b7-977b-f56f004298b5 | grep properties
| properties             | {u'cpu_arch': u'x86_64', u'root_device': {u'name': u'/dev/VDA'}, u'cpus': u'2', u'capabilities': u'cpu_vt:true,cpu_aes:true,cpu_hugepages_1g:true,cpu_hugepages:true,boot_option:local', u'memory_mb': u'6144', u'local_gb': u'19'}

[stack@undercloud-0 ~]$ openstack overcloud node introspect --all-manageable --provide
Started Mistral Workflow. Execution ID: 025cfe95-2749-48fa-aacb-93e444304210
Waiting for introspection to finish...
Introspection for UUID aa87a284-5b85-41b7-bc61-7a08cd6b9dd5 finished successfully.
Introspection for UUID aa13e78d-d316-47b7-977b-f56f004298b5 finished successfully.
Introspection completed.

Comment 12 errata-xmlrpc 2019-01-16 17:10:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0078