Bug 1571947

Summary: ceph-client role key management bugs
Product: Red Hat OpenStack Reporter: John Fulton <johfulto>
Component: ceph-ansibleAssignee: John Fulton <johfulto>
Status: CLOSED ERRATA QA Contact: Yogev Rabl <yrabl>
Severity: high Docs Contact:
Priority: high    
Version: 13.0 (Queens)CC: gfidente, jjoyce, johfulto, knylande, rhos-flags
Target Milestone: betaKeywords: Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: ceph-ansible-3.1.0-0.1.beta8.el7cp Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:53:37 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1568157, 1569290    
Bug Blocks:    

Description John Fulton 2018-04-25 19:04:12 UTC
Deployments fail because ceph-ansible's ceph-client role either fails to create keys or change their permissions.

Comment 1 John Fulton 2018-04-25 19:07:43 UTC
The depends-on bugs 1568157 and 1569290 are fixed by ceph-ansible-3.1.0-0.1.beta8.el7cp

Comment 13 errata-xmlrpc 2018-06-27 13:53:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086