Bug 1572978

Summary: Clang6 package does not contain sanitiser libraries
Product: [Fedora] Fedora Reporter: Andreas Osowski <th0br0>
Component: clangAssignee: Dave Airlie <airlied>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: airlied, davejohansen, ravnzon, sbergman, siddharth.kde, tstellar
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-04-29 12:07:04 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Andreas Osowski 2018-04-29 12:03:51 UTC
Description of problem:
Missing libraries for building with one of the sanitisers enabled.

Version-Release number of selected component (if applicable):
clang-6.0.0-5.fc29.x86_64
clang-tools-extra-6.0.0-5.fc29.x86_64
clang-devel-6.0.0-5.fc29.x86_64
clang-libs-6.0.0-5.fc29.x86_64


How reproducible:
Always

Steps to Reproduce:
1. echo "int main(int argc, char** argv) { return 0; }" > test.c
2. clang -fsanitize=memory test.c
3.

Actual results:
/usr/bin/ld: cannot find /usr/lib64/clang/6.0.0/lib/linux/libclang_rt.msan-x86_64.a: No such file or directory


Expected results:
Binary builds and runs without issues.

Additional info:
`clang5.0-libs-5.0.1-4.fc29.x86_64` contains the relevant libraries for 5.0.1.

Comment 1 Andreas Osowski 2018-04-29 12:07:04 UTC
Bad bug report, looks like `compiler-rt` wasn't upgraded automatically. Apologies for the noise.