Bug 1573107

Summary: openmpi: Partial build flags injection
Product: [Fedora] Fedora Reporter: Florian Weimer <fweimer>
Component: openmpiAssignee: Florian Weimer <fweimer>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 28CC: dakingun, dledford, hladky.jiri, orion
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openmpi-2.1.1-10.fc29 openmpi-2.1.1-10.fc28 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-02-21 01:38:39 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1539083    

Description Florian Weimer 2018-04-30 08:14:59 UTC
openmpi-2.1.1-9.fc28.x86_64 doesn't use the full LDFLAGS from redhat-rpm-config, due to the usual libtool problem.  I will try to rebuild it with the current flags, which changed since February and are supposedly more friendly to libtool.

Comment 1 Fedora Update System 2018-04-30 08:44:33 UTC
openmpi-2.1.1-10.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-6243955a16

Comment 2 Florian Weimer 2018-04-30 10:47:35 UTC
The rawhide build should be okay.

Comment 3 Fedora Update System 2018-04-30 19:54:51 UTC
openmpi-2.1.1-10.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-6243955a16

Comment 4 Fedora Update System 2019-02-21 01:38:39 UTC
openmpi-2.1.1-10.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.