Bug 1573251

Summary: ASUS GL702ZC: Fan at full speed at shutdown
Product: [Fedora] Fedora Reporter: Turgut Kalfaoglu <turgut>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 27CC: airlied, bskeggs, ewk, hdegoede, ichavero, itamar, jarodwilson, jglisse, john.j5live, jonathan, josef, kernel-maint, linville, mchehab, mjg59, steved, turgut
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-10-02 06:29:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
lshw output none

Description Turgut Kalfaoglu 2018-04-30 15:28:12 UTC
Created attachment 1428849 [details]
lshw output

Description of problem:

After upgrading to kernel 4.16.3-200.fc27.x86_64, when I select shutdown in F27,
the screen turns black and the laptop's fan goes on full blast, and stays that way until I hold the power button down for 5 seconds to turn off the laptop.
The previous F27 kernel did not exhibit this problem.

Version-Release number of selected component (if applicable):

4.16.3-200.fc27.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Select shutdown from gnome desktop
2. Click on shutdown,
3. After 1 minute, the fan is at full blast and shutdown is not completed.

Additional info:

lshw output attached

Comment 1 Welly Wu 2018-07-12 11:56:19 UTC
I own an ASUS ROG STRIX GL702ZC and I installed Red Hat Fedora 28 Workstation 64 bit. I get a similar problem when trying to shut down my gaming notebook PC. Either it does not shut down completely or the fans go at full speed and I have to press and hold down the power button to turn it off after it has partially shut down. How do I get more technical information to provide to this bug report in order to solve it?

Comment 2 Turgut Kalfaoglu 2018-07-13 07:18:08 UTC
I have not seen that problem lately. I am hoping it has gone away with the latest kernels..

Comment 3 Welly Wu 2018-07-13 10:05:06 UTC
Linux kernel 4.17.6 64 bit solves this problem in my experience. I can shut down and power off my GL702ZC and restarting it works normally too. This is solved for me for now. If it acts up again, then I will update this.

Comment 4 Justin M. Forbes 2018-07-23 15:23:45 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 27 kernel bugs.

Fedora 27 has now been rebased to 4.17.7-100.fc27.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 28, and are still experiencing this issue, please change the version to Fedora 28.

If you experience different issues, please open a new bug report for those.

Comment 5 Laura Abbott 2018-10-01 21:21:15 UTC
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 27 kernel bugs.
 
Fedora 27 has now been rebased to 4.18.10-100.fc27.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 28 or Fedora 29, and are still experiencing this issue, please change the version to Fedora 28 or 29.
 
If you experience different issues, please open a new bug report for those.

Comment 6 Turgut Kalfaoglu 2018-10-02 06:29:13 UTC
Thank you -- the problem has disappeared ever since I started using newer kernels.