Bug 1573411

Summary: NCAT_REMOTE_ADDR{_PORT} and source address don't work in UDP mode
Product: Red Hat Enterprise Linux 7 Reporter: Pavel Zhukov <pzhukov>
Component: nmapAssignee: Pavel Zhukov <pzhukov>
Status: CLOSED ERRATA QA Contact: Jaroslav Aster <jaster>
Severity: unspecified Docs Contact: Ioanna Gkioka <igkioka>
Priority: unspecified    
Version: 7.5CC: jaster, myamazak, psklenar, thozza
Target Milestone: rcKeywords: EasyFix, FutureFeature, Patch
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: nmap-6.40-16.el7 Doc Type: Bug Fix
Doc Text:
*ncat* now correctly sets environment variables in UDP mode Previously, the *ncat* utility did not set environment variables for User Datagram Protocol (UDP) connections properly. As a consequence, user's scripts failed in UDP mode. This update sets some internal values, and environment variables now are set properly.
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-10-30 07:47:49 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1070056, 1071172, 1544850    

Description Pavel Zhukov 2018-05-01 06:45:42 UTC
In udp mode ncat application doesn't populate environment variables.
Backport of https://github.com/nmap/nmap/commit/e8b73078fd56a4d16ffa9cbb51f43ac75c5f7f1f is needed

Comment 10 errata-xmlrpc 2018-10-30 07:47:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3023