Bug 1573586

Summary: SELinux is preventing systemd-gpt-aut from 'open' accesses on the archivo /usr/lib/systemd/libsystemd-shared-231.so.
Product: [Fedora] Fedora Reporter: Miguel Zúñiga <mzuniga>
Component: selinux-policyAssignee: Lukas Vrabec <lvrabec>
Status: CLOSED EOL QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 27CC: dwalsh, lvrabec, mgrepl, plautrba
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:d9f6bee2542c8d741c062b3d81710da82bfde018e55e6fd70a2dd5deaf8df5be;VARIANT_ID=workstation;
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-11-30 22:49:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Miguel Zúñiga 2018-05-01 18:14:38 UTC
Description of problem:
SELinux is preventing systemd-gpt-aut from 'open' accesses on the archivo /usr/lib/systemd/libsystemd-shared-231.so.

*****  Plugin catchall (100. confidence) suggests   **************************

Si cree que de manera predeterminada se debería permitir a systemd-gpt-aut el acceso open sobre  libsystemd-shared-231.so file.     
Then debería reportar esto como un error.
Puede generar un módulo de política local para permitir este acceso.
Do
permita el acceso temporalmente ejecutando:
# ausearch -c 'systemd-gpt-aut' --raw | audit2allow -M mi-systemdgptaut
# semodule -X 300 -i mi-systemdgptaut.pp

Additional Information:
Source Context                system_u:system_r:systemd_gpt_generator_t:s0
Target Context                system_u:object_r:init_exec_t:s0
Target Objects                /usr/lib/systemd/libsystemd-shared-231.so [ file ]
Source                        systemd-gpt-aut
Source Path                   systemd-gpt-aut
Port                          <Desconocido>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           systemd-231-12.fc25.x86_64
Policy RPM                    selinux-policy-3.13.1-191.24.fc24.noarch selinux-
                              policy-3.13.1-225.6.fc25.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.9.6-100.fc24.x86_64 #1 SMP Thu
                              Jan 26 10:21:30 UTC 2017 x86_64 x86_64
Alert Count                   1
First Seen                    2017-02-05 01:08:06 CST
Last Seen                     2017-02-05 01:08:06 CST
Local ID                      cb133d51-9075-42ba-9c4e-2ad461a004c8

Raw Audit Messages
type=AVC msg=audit(1486278486.749:408): avc:  denied  { open } for  pid=5464 comm="systemd-gpt-aut" path="/usr/lib/systemd/libsystemd-shared-231.so" dev="sda15" ino=141810 scontext=system_u:system_r:systemd_gpt_generator_t:s0 tcontext=system_u:object_r:init_exec_t:s0 tclass=file permissive=0


Hash: systemd-gpt-aut,systemd_gpt_generator_t,init_exec_t,file,open

Version-Release number of selected component:
selinux-policy-3.13.1-191.24.fc24.noarch
selinux-policy-3.13.1-225.6.fc25.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.3
hashmarkername: setroubleshoot
kernel:         4.16.5-200.fc27.x86_64
type:           libreport

Comment 1 Ben Cotton 2018-11-27 14:24:47 UTC
This message is a reminder that Fedora 27 is nearing its end of life.
On 2018-Nov-30  Fedora will stop maintaining and issuing updates for
Fedora 27. It is Fedora's policy to close all bug reports from releases
that are no longer maintained. At that time this bug will be closed as
EOL if it remains open with a Fedora  'version' of '27'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 27 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 2 Ben Cotton 2018-11-30 22:49:55 UTC
Fedora 27 changed to end-of-life (EOL) status on 2018-11-30. Fedora 27 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.