Bug 1573678

Summary: Unrecognized arguments: ‐‐allowerasing
Product: [Fedora] Fedora Reporter: Isaque Galdino <igaldino>
Component: dnf-plugin-system-upgradeAssignee: Orphan Owner <extras-orphan>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 27CC: extras-orphan
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-05-02 12:42:09 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Isaque Galdino 2018-05-01 23:12:26 UTC
Description of problem:
I have some packages that prevent from upgrading the system, so I used the option --allowerasing but system-upgrade doesn't recognize it.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1. sudo dnf system-upgrade download ‐‐allowerasing --releasever=28

Actual results:
dnf system-upgrade: error: unrecognized arguments: ‐‐allowerasing

Expected results:
Run the command right

Additional info:

Comment 1 Isaque Galdino 2018-05-02 12:42:09 UTC
The problem was actually that I was copying the --allowerasing command from this page: https://fedoramagazine.org/upgrading-fedora-27-fedora-28/
and it seems that it mess up with the characters.

So the solution is to just type it in the command line.