Bug 1573694

Summary: Samsung Chromebook keyboard not working after update to kernel 4.16.*
Product: [Fedora] Fedora Reporter: rahul.juliato
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 28CC: airlied, bskeggs, ewk, hdegoede, ichavero, itamar, jarodwilson, jcline, jforbes, jglisse, john.j5live, jonathan, josef, kernel-maint, linville, mchehab, mjg59, rahul.juliato, steved
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-07-24 20:02:02 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description rahul.juliato 2018-05-02 03:16:38 UTC
Description of problem:
Samsung Chromebook keyboard not working after update to kernel 4.16.*, can't use it unless an external USB keyboard is connected.

There was nothing on /var/messages related to keyboard or other stuff.

I'm desperate using 4.15 kernel but fedora keeps releasing new 4.16 kernels with the same problem.


Version-Release number of selected component (if applicable):
-

How reproducible:


Steps to Reproduce:
1. Select 4.16 kernel on grub

Actual results:
No keyboard working

Expected results:
Keyboard to work

Additional info:

Comment 1 Jeremy Cline 2018-05-23 19:41:53 UTC
Hi,

Without the exact hardware model and dmesg logs, I can't even begin to guess what might be wrong. I recommend testing to make sure this isn't already fixed in 4.17 by installing the Rawhide kernel, and if it's not, bisecting[0] the kernel to see what commit broke the keyboard.

[0] https://docs.fedoraproject.org/quick-docs/en-US/kernel/troubleshooting.html#bisecting-the-kernel

Comment 2 Justin M. Forbes 2018-07-23 15:08:59 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 28 kernel bugs.

Fedora 28 has now been rebased to 4.17.7-200.fc28.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 3 rahul.juliato 2018-07-24 17:34:32 UTC
It was corrected in 4.17-6.

Thanks!

Comment 4 Justin M. Forbes 2018-07-24 20:02:02 UTC
Thanks for the update.