Bug 1573774

Summary: Keyboard layout is only English at gnome login prompt
Product: [Fedora] Fedora Reporter: Peter <cyclonizer>
Component: gnome-shellAssignee: Owen Taylor <otaylor>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 28CC: cyclonizer, fmuellner, kursat.maestro, otaylor, rastus.vernon, t.sailer
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-10 22:14:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Peter 2018-05-02 08:57:14 UTC
Description of problem:

When at the gnome login screen, no matter what keyboard layout I choose, it'll still be the English one when I actually type.
My installed keyboard layouts: Swedish (Svdvorak), Swedish and English.
After I've logged into Gnome I can pick a keyboard layout without a problem.

Steps to Reproduce:
1. Install the following keyboard layouts in the following priority (first layout is on top): Swedish (Svdvorak), Swedish and English
2. Restart/logout 
3. Try to use a different layout than English at the login-screen

Actual results:
No matter what layout picked, It'll be English

Expected results:
The actual layout you pick at the login-screen should work

Additional info:
This problem occurred after upgrading from Fedora 27.
The problem seems to go away if I remove the English keyboard layout entirely.

Comment 1 Peter 2018-05-02 09:02:44 UTC
I noticed that you actually need to restart the system after installing the keyboard layouts, just logging out (as described in the problem description) is not sufficient to reproduce the problem.

Comment 2 Thomas Sailer 2018-05-02 13:10:07 UTC
Same here, with de and en

Comment 3 Rastus Vernon 2018-05-04 00:43:17 UTC
According to a comment on Bodhi,[1] this bug was introduced in the day zero fix for bug 1569211. That update might not have had enough time for testing.

[1]: https://bodhi.fedoraproject.org/updates/gnome-shell-3.28.1-3.fc28#comment-777931

Comment 4 Peter 2018-05-16 13:13:37 UTC
I just did a dnf upgrade and a reboot (Fedora 28) and it seems like the bug has been resolved?
Can someone confirm?

Comment 5 Kürşat 2018-05-17 01:47:04 UTC
same problem here with tr Turkish layout,
installed keyboard layouts: Turkish, Russian and English.

Comment 6 Rastus Vernon 2018-05-25 18:13:56 UTC
This is a duplicate of bug 1573923.