Bug 1574430

Summary: [geo-rep]: Old and New names exists errors
Product: Red Hat Gluster Storage Reporter: Rochelle <rallan>
Component: geo-replicationAssignee: Shwetha K Acharya <sacharya>
Status: CLOSED DEFERRED QA Contact: Rahul Hinduja <rhinduja>
Severity: low Docs Contact:
Priority: low    
Version: rhgs-3.4CC: atumball, csaba, khiremat, rhs-bugs, sankarshan, storage-qa-internal
Target Milestone: ---Keywords: ZStream
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-12-13 12:39:49 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Rochelle 2018-05-03 10:11:44 UTC
Description of problem:
=======================
While doing a cp and rmdir of /etc in a for loop the following crashes were observed.

[2018-04-30 09:31:56.876420] E [resource(slave):850:entry_ops] <top>: Directory Rename failed. Both Old and New directories exists      new=.gfid/b0a1978b-c21c-4394-8bc5-fca3055c5822/etc.1    old=.gfid/b0a1978b-c21c-4394-8bc5-fca3055c5822/etc.1
[2018-04-30 09:33:56.280086] E [resource(slave):850:entry_ops] <top>: Directory Rename failed. Both Old and New directories exists      new=.gfid/b0a1978b-c21c-4394-8bc5-fca3055c5822/etc.1    old=.gfid/b0a1978b-c21c-4394-8bc5-fca3055c5822/etc.1
[2018-04-30 09:35:23.758975] E [resource(slave):850:entry_ops] <top>: Directory Rename failed. Both Old and New directories exists      new=.gfid/b0a1978b-c21c-4394-8bc5-fca3055c5822/etc.1    old=.gfid/b0a1978b-c21c-4394-8bc5-fca3055c5822/etc.1
[2018-04-30 09:37:06.330960] W [syncdutils(slave):549:errno_wrap] <top>: reached maximum retries        args=['.gfid/766ad3bd-d1fc-4347-964b-d388bc4e3831/updfstab']    error=[Errno 95] Operation not supported: '.gfid/766ad3bd-d1fc-4347-964b-d388bc4e3831/updfstab'


Version-Release number of selected component (if applicable):
=============================================================
glusterfs-geo-replication-3.12.2-8.el7rhgs.x86_64


How reproducible:
=================
1/1


Steps to Reproduce:
==================
1.create and start a geo-rep relationship between master(3x3) and slave(3x3)
2.On the master mount, do a cp and rmdir in loop:
for i in {1..10}; do cp -rf /etc etc.1 ; sleep 10 ; rm -rf etc.1 ; sleep 10 ; done

Actual results:
===============
Old and New names exist errors were observed

Expected results:
=================
There shouldn't be any errors.

Comment 5 Amar Tumballi 2018-12-13 12:39:49 UTC
> Since the data sync is fine and the crashes are transitional, marking this beyond 3.4

No changes are required in code, we should document that these warnings in logs are common for the given workload. Will not be working on this in near time.