Bug 1575109

Summary: [RFE][upstream][v2v] Currently only the CSV import will let you view and select an already migrated VM — the discovery process does not
Product: Red Hat CloudForms Management Engine Reporter: Kedar Kulkarni <kkulkarn>
Component: UI - OPSAssignee: Brett Thurber <bthurber>
Status: CLOSED NOTABUG QA Contact: Kedar Kulkarni <kkulkarn>
Severity: medium Docs Contact:
Priority: low    
Version: 5.9.0CC: bthurber, cpelland, dagur, dmetzger, fdupont, hkataria, kkulkarn, lavenel, mpovolny, obarenbo, pvauter, smallamp
Target Milestone: GAKeywords: FutureFeature, Reopened
Target Release: 5.10.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: v2v
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-03-07 07:31:44 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Kedar Kulkarni 2018-05-04 19:09:54 UTC
Description of problem:

Currently only the CSV import in migration plan wizard will let you view and select an already migrated VM — the discovery process does not. If we allow discovery process to show migrated VMs then that will be one less reason to use csv file. 

Version-Release number of selected component (if applicable):
master.20180503231749_2aba99c


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Sudhir Mallamprabhakara 2018-05-15 18:54:35 UTC
https://github.com/priley86/miq_v2v_ui_plugin/issues/293

Comment 3 Brett Thurber 2018-05-22 18:53:09 UTC
Updated link to PR.  https://github.com/manageiq/miq_v2v_ui_plugin/issues/293

I don't expect this will change unltess it becomes a blocker for QE.

Comment 4 Kedar Kulkarni 2018-05-23 17:02:09 UTC
Brett, currently I cannot see migrated VM in the list if I use "Discover VMs", I can see it only if I import it via CSV. it may not be blocker though as workaround exists.

Comment 5 Brett Thurber 2018-05-24 01:25:42 UTC
This is expected behavior KK.  It's the way the backend validation is made.  This is probably not a bug .

Comment 6 Brett Thurber 2018-06-26 04:54:49 UTC
Closing as not a bug.

Comment 8 Fabien Dupont 2019-03-07 07:31:44 UTC
There's no update since July 2108, so it's apparently not a problem for QE as IMS 1.0 and 1.1 have been QE'd and released.
Closing as NOTABUG.