Bug 1575650

Summary: initial-setup fails - ImportError: cannot import name 'USER'
Product: [Fedora] Fedora Reporter: Paul Whalen <pwhalen>
Component: initial-setupAssignee: Martin Kolman <mkolman>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: awilliam, mkolman, robatino, v.podzimek+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: armhfp   
OS: Linux   
Whiteboard:
Fixed In Version: initial-setup-0.3.61-1 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-05-14 16:53:21 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 245418, 1517011    
Attachments:
Description Flags
journalctl none

Description Paul Whalen 2018-05-07 14:19:54 UTC
Description of problem:
initial-setup fails in Fedora-Rawhide-20180506.n.0

Version-Release number of selected component (if applicable):
initial-setup-0.3.60-1.fc29.armv7hl

[root@localhost ~]# systemctl status initial-setup
‚óŹ initial-setup.service - Initial Setup configuration program
   Loaded: loaded (/usr/lib/systemd/system/initial-setup.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Mon 2018-05-07 10:05:44 EDT; 2min 31s ago
  Process: 596 ExecStart=/usr/libexec/initial-setup/run-initial-setup (code=exited, status=1/FAILURE)
  Process: 587 ExecStartPre=/bin/plymouth quit (code=exited, status=0/SUCCESS)
  Process: 578 ExecStartPre=/bin/kill -SIGRTMIN+21 1 (code=exited, status=0/SUCCESS)
 Main PID: 596 (code=exited, status=1/FAILURE)

May 07 10:05:43 localhost run-initial-setup[596]: Traceback (most recent call last):
May 07 10:05:43 localhost run-initial-setup[596]:   File "/usr/libexec/initial-setup/initial-setup-text", line 3, in <module>
May 07 10:05:43 localhost run-initial-setup[596]:     from initial_setup import InitialSetup, InitialSetupError
May 07 10:05:43 localhost run-initial-setup[596]:   File "/usr/lib/python3.6/site-packages/initial_setup/__init__.py", line 22, in <module>
May 07 10:05:43 localhost run-initial-setup[596]:     from pyanaconda.modules.common.constants.services import BOSS, LOCALIZATION, TIMEZONE, USER, \
May 07 10:05:43 localhost run-initial-setup[596]: ImportError: cannot import name 'USER'
May 07 10:05:44 localhost initial-setup[834]: Initial Setup failed, keeping enabled
May 07 10:05:44 localhost systemd[1]: initial-setup.service: Main process exited, code=exited, status=1/FAILURE
May 07 10:05:44 localhost systemd[1]: initial-setup.service: Failed with result 'exit-code'.
May 07 10:05:44 localhost systemd[1]: Failed to start Initial Setup configuration program.

Comment 1 Paul Whalen 2018-05-07 14:23:21 UTC
Created attachment 1432610 [details]
journalctl

Comment 2 Adam Williamson 2018-05-07 23:54:12 UTC
This is also affecting x86_64 (it breaks the KDE 'install without creating a user during anaconda' test in openQA). Nominating as a Beta blocker, criterion "A working mechanism to create a user account must be clearly presented during installation and/or first boot of the installed system" - this is most obviously violated for ARM release-blocking images, as without i-s there is *no* user creation mechanism for these images.

Comment 3 Martin Kolman 2018-05-09 11:17:28 UTC
PR: https://github.com/rhinstaller/initial-setup/pull/55

Comment 4 Adam Williamson 2018-05-14 16:53:21 UTC
https://openqa.fedoraproject.org/tests/236905 indicates that this is fixed (the package build was done and that is the openqa test that previously failed, now passing).