Bug 1575908

Summary: [RFE] AuditLog Feature
Product: Red Hat Gluster Storage Reporter: Bhumika Goyal <bgoyal>
Component: gluster-blockAssignee: Bhumika Goyal <bgoyal>
Status: CLOSED ERRATA QA Contact: Rachael <rgeorge>
Severity: high Docs Contact:
Priority: urgent    
Version: cns-3.10CC: akrishna, atumball, bgoyal, kramdoss, nberry, pkarampu, pprakash, prasanna.kalever, rhs-bugs, sankarshan, vbellur, xiubli
Target Milestone: ---Keywords: FutureFeature
Target Release: OCS 3.11   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: gluster-block-0.2.1-27.el7rhgs Doc Type: Enhancement
Doc Text:
The CLI audit logs have been added to capture every CLI command and its response. This makes logs more detailed and easier to understand the gluster-block CLI operations history, which will improve debugability.
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-10-24 04:52:58 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1632821    

Description Bhumika Goyal 2018-05-08 09:14:57 UTC
Description of problem:

Right now there is no mechanism that records the requests and responses that the gluster-block daemon receives. And therefore, it becomes difficult to troubleshoot the bugs.

Changes needed: 

Develop a feature that will record the response status and the requests received by gluster-block daemon for the operations Create/Delete/Modify. The logs will record  the request, response status(success/failure) and the response string received from the servers.

The logging format is:
In case of success:
[time] : command string at CLI: SUCCESS: Response string

In case of failure:
[time] : command string at CLI: FAILURE: Response string

Design discussion link:
https://github.com/gluster/gluster-block/issues/22

Comment 9 Anjana KD 2018-10-12 05:25:14 UTC
Updated the changes.

Comment 11 errata-xmlrpc 2018-10-24 04:52:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2987