Bug 1576557

Summary: non-root user presented with cryptic error "No GPG-verified eggs can be found"
Product: Red Hat Enterprise Linux 7 Reporter: Aaron Weitekamp <aweiteka>
Component: insights-clientAssignee: jcrafts
Status: CLOSED CURRENTRELEASE QA Contact: Jeff Needle <jneedle>
Severity: medium Docs Contact:
Priority: high    
Version: 7.6CC: ahumbe, alng, dajohnso, ecerqueira, jcrafts, jnewton, kdixon, klape, lphiri, pakotvan, robwilli, sgallagh
Target Milestone: rcKeywords: ZStream
Target Release: 7.6   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1730798 1735925 (view as bug list) Environment:
Last Closed: 2020-06-10 13:13:40 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1122832, 1730798, 1735925    

Description Aaron Weitekamp 2018-05-09 18:13:52 UTC
Description of problem:
insights-client CLI returns cryptic error message when run as non-root.

[cloud-user@localhost] $ insights-client --register
No GPG-verified eggs can be found
[cloud-user@localhost] $ sudo insights-client --register
... (success)

Version-Release number of selected component (if applicable):
$ sudo insights-client --version
Client: 3.0.3-9
Core: 3.0.4-3

How reproducible:
when using CLI as non-root user

Steps to Reproduce:
1. Login or SSH to system as non-root, e.g. cloud-user
2. run insights-client without sudo

Actual results:
No matter what args/options CLI exits with 1: "No GPG-verified eggs can be found"

Expected results:
1. Help should always be returned regardless of user permission, e.g. insights-client -h
2. If user does not have required permissions then display helpful error, such as "insights-client must be run as root user"

Additional info:

Comment 6 Jeff Needle 2019-06-04 12:31:43 UTC
*** Bug 1716934 has been marked as a duplicate of this bug. ***