Bug 1576826

Summary: Install success but registry-console fail
Product: OpenShift Container Platform Reporter: Chris Evich <cevich>
Component: InstallerAssignee: Scott Dodson <sdodson>
Status: CLOSED DUPLICATE QA Contact: Johnny Liu <jialiu>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 3.10.0CC: aos-bugs, jokerman, mmccomas, vrutkovs
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-05-10 14:06:36 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Chris Evich 2018-05-10 13:14:14 UTC
Description of problem:
Running installer was successful, all deployments up except registry console.

Version-Release number of selected component (if applicable):
commit 2fc279f23c7d0a7375b6cfd5083d1f810a87e003 (grafted, HEAD -> master, origin/master, origin/HEAD)
Author: Scott Dodson <sdodson@redhat.com>
Date:   Wed May 9 15:47:51 2018 -0400

How reproducible:
Unknown, guessing likely but time-consuming.

Steps to Reproduce:
1. ansible-playbook -i /path/to/inventory.yml ./playbooks/prerequisites.yml
2. ansible-playbook -i /path/to/inventory.yml ./playbooks/deploy_cluster.yml

Actual results:
INSTALLER STATUS ****************************************************************************************
Initialization             : Complete (0:00:26)
Health Check               : Complete (0:00:04)
Node Preparation           : Complete (0:04:30)
etcd Install               : Complete (0:00:55)
Master Install             : Complete (0:05:49)
Master Additional Install  : Complete (0:01:59)
Hosted Install             : Complete (0:01:52)
Web Console Install        : Complete (0:00:43)
Service Catalog Install    : Complete (0:02:47)
Wednesday 09 May 2018  17:06:22 -0400 (0:00:00.024)       0:19:51.769 ********* 
=============================================================================== 
openshift_node : install needed rpm(s) --------------------------------------------------------- 115.22s
openshift_control_plane : Verify that the control plane is running ----------------------------- 110.47s
openshift_node : Install node, clients, and conntrack packages ---------------------------------- 37.73s
openshift_web_console : Verify that the console is running -------------------------------------- 25.93s
openshift_manageiq : Configure role/user permissions -------------------------------------------- 25.46s
cockpit : Install cockpit-ws -------------------------------------------------------------------- 20.93s
tuned : Ensure files are populated from templates ----------------------------------------------- 15.17s
template_service_broker : Verify that TSB is running -------------------------------------------- 14.85s
openshift_node : Install iSCSI storage plugin dependencies -------------------------------------- 14.17s
openshift_node : Install Ceph storage plugin dependencies --------------------------------------- 14.13s
openshift_hosted : Create default projects ------------------------------------------------------ 13.52s
ansible_service_broker : Create custom resource definitions for asb ----------------------------- 13.45s
cockpit-ui : fetch the docker-registry route ---------------------------------------------------- 12.01s
openshift_control_plane : Add iptables allow rules ---------------------------------------------- 11.66s
openshift_manage_node : Retrieve non-infra, non-master nodes that are not yet labeled compute --- 11.49s
openshift_hosted : Create OpenShift router ------------------------------------------------------ 11.25s
template_service_broker : Apply template file --------------------------------------------------- 10.95s
openshift_control_plane : Update master static pods ---------------------------------------------- 9.42s
openshift_service_catalog : oc_process ----------------------------------------------------------- 9.30s
openshift_manage_node : Label nodes -------------------------------------------------------------- 9.15s

-but-


In project default on server https://172.16.12.24:8443

https://docker-registry-default.router.default.svc.cluster.local (passthrough) (svc/docker-registry)
  dc/docker-registry deploys registry.X.Y.Z/openshift3/ose-docker-registry:v3.10 
    deployment #1 deployed 16 hours ago - 1 pod

svc/kubernetes - 172.30.0.1 ports 443->8443, 53->8053, 53->8053

https://registry-console-default.router.default.svc.cluster.local (passthrough) (svc/registry-console)
  dc/registry-console deploys registry.access.redhat.com/openshift3/registry-console:v3.10 
    deployment #1 failed 16 hours ago: config change

svc/router - 172.30.91.156 ports 80, 443, 1936
  dc/router deploys registry.X.Y.Z/openshift3/ose-haproxy-router:v3.10 
    deployment #1 deployed 16 hours ago - 1 pod

daemonset/dockergc manages openshift3/ose:v3.10
  generation #1 running for 16 hours


Expected results:
Installer success AND installation success

Additional info:
See attached

Description of problem:

Version-Release number of the following components:
rpm -q openshift-ansible
rpm -q ansible
ansible --version

Comment 4 Chris Evich 2018-05-10 13:33:04 UTC
Note: <vrutkovs> cevich: 'registry.access.redhat.com/openshift3/registry-console:v3.10' - this image doesn't exist yet

Comment 5 Scott Dodson 2018-05-10 14:06:36 UTC

*** This bug has been marked as a duplicate of bug 1516534 ***