Bug 1577052

Summary: "rhui-manager subscriptions list --available --pool-only" prints some invisible garbage
Product: Red Hat Update Infrastructure for Cloud Providers Reporter: Radek Bíba <rbiba>
Component: RHUAAssignee: Martin Minar <mminar>
Status: CLOSED ERRATA QA Contact: Vratislav Hutsky <vhutsky>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 3.0.3CC: lwilliam, mminar
Target Milestone: 3.0.4Flags: mminar: needinfo?
Target Release: 3.0.x   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-07-10 16:00:36 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Radek Bíba 2018-05-11 05:48:37 UTC
Description of problem:
As a RHUI admin, I'd like to take the output from "rhui-manager subscriptions list --available --pool-only" and use it as the parameter of "rhui-manager subscriptions register --pool ..."; this assumes that I only have a single pool available. However, I can't do that using $() or ``, as the output contains more than just the pool ID. The ~/.rhui/rhui.log file says:

The pool ID ESC[0m8a85f98b61e217aa0161ed24079a583e is not available

Check the output using | od -a to see the extra characters.

Version-Release number of selected component (if applicable):
RHUI 3.0.3.

Comment 6 errata-xmlrpc 2018-07-10 16:00:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2153