Bug 1577199

Summary: RFE: Ship selinux-policy in the package
Product: [Fedora] Fedora Reporter: Honza Horak <hhorak>
Component: community-mysqlAssignee: Michal Schorm <mschorm>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: hhorak, jstanek, louzaoh, mschorm
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: community-mysql-8.0.17-2.fc30 community-mysql-8.0.17-2.fc29 Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-09-04 02:26:09 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1665643    
Bug Blocks:    

Description Honza Horak 2018-05-11 13:00:33 UTC
Description of problem:
In order to avoid requests for changing selinux-policy package, we should pack mysql module of the SElinux policy in the server package itself. Similarly for MariaDB.

Comment 1 Michal Schorm 2018-08-23 10:20:01 UTC
Can you please give us the current status, Jakub?

Comment 2 Jakub JanĨo 2018-08-28 07:07:51 UTC
Hi, there is package mysql-selinux in f29-30 which works for both mysql and mariadb. Just adding as Requires, should work. There should land all new fixes, which are then synced with selinux-policy package.

Comment 3 Michal Schorm 2019-01-17 10:14:15 UTC
I added macros for it in both MariaDB & MySQL.
They can be enabled by simply setting the appropriate macro on the top of the SPECfile to "1".

However for now, I leave it disabled, because of a bug in 'selinux-policy'

Comment 4 Fedora Update System 2019-08-26 22:46:42 UTC
FEDORA-2019-96516ce0ac has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-96516ce0ac

Comment 5 Fedora Update System 2019-08-26 22:46:51 UTC
FEDORA-2019-c106e46a95 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-c106e46a95

Comment 6 Fedora Update System 2019-08-27 15:43:50 UTC
mysql-8.0-2920190823234131.6c81f848 has been pushed to the Fedora 29 Modular testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2019-74e1876b27

Comment 7 Fedora Update System 2019-08-27 16:17:54 UTC
mysql-8.0-3020190823234131.a5b0195c has been pushed to the Fedora 30 Modular testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2019-5954e4c3bb

Comment 8 Fedora Update System 2019-08-27 18:22:02 UTC
community-mysql-8.0.17-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-c106e46a95

Comment 9 Fedora Update System 2019-08-27 18:27:43 UTC
community-mysql-8.0.17-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-96516ce0ac

Comment 11 Fedora Update System 2019-09-04 02:26:09 UTC
mysql-8.0-3020190823234131.a5b0195c has been pushed to the Fedora 30 Modular stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2019-09-04 03:11:43 UTC
community-mysql-8.0.17-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2019-09-04 03:18:37 UTC
mysql-8.0-2920190823234131.6c81f848 has been pushed to the Fedora 29 Modular stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2019-09-04 04:06:14 UTC
community-mysql-8.0.17-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.