Bug 1577227

Summary: Upgrade step 20160225115638 RemoveDefaultUserRole: migrating fail
Product: Red Hat Satellite Reporter: Jan Jansky <jjansky>
Component: UpgradesAssignee: satellite6-bugs <satellite6-bugs>
Status: CLOSED WONTFIX QA Contact: Nikhil Kathole <nkathole>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.3.1CC: bkearney, inecas, mbacovsk, mmccune
Target Milestone: UnspecifiedKeywords: PrioBumpField, Triaged
Target Release: UnusedFlags: bkearney: needinfo? (mmccune)
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jan Jansky 2018-05-11 13:59:02 UTC
Description of problem: Upgrade step 20160225115638 RemoveDefaultUserRole: migrating will fail if any user of usergroup have assigned role "Default user" or "Anonymous"


How reproducible:
So far i solve this with 2 customers and do not tried to reproduce


Steps to Reproduce:
1. Create User or Usergroup
2. Add role Default user or Anonymous to create user or usergroup
3. Upgrade satellite

Actual results:
[DEBUG 2018-05-10 13:48:19 main] == 20160225115638 RemoveDefaultUserRole: migrating ============================
[ERROR 2018-05-10 13:48:19 main] foreman-rake db:migrate failed! Check the output for error!
[ERROR 2018-05-10 13:48:19 main] Upgrade step migrate_foreman failed. Check logs for more information.


Expected results:
upgrade will work


Additional info:
It seems that migration step only try to remove role Default User and Anonymous instead of removing first related records from user_roles.

When records from user_roles are removed upgrade step will work perfectly.

Comment 5 Bryan Kearney 2019-12-03 16:34:32 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 6 Bryan Kearney 2020-01-15 20:30:09 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.

Comment 7 Bryan Kearney 2020-01-15 20:30:13 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.