Bug 1577283

Summary: vmwrite error: reg 401e value 2020 (err 12)
Product: [Fedora] Fedora Reporter: Steve Dickson <steved>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 28CC: airlied, bskeggs, ewk, hdegoede, ichavero, itamar, jarodwilson, jcline, jglisse, john.j5live, jonathan, josef, kernel-maint, linville, mchehab, mjg59, steved
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-05-11 16:19:17 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Steve Dickson 2018-05-11 15:24:02 UTC
Description of problem:
Bring up a VM I start seeing these messages from all 4 cpus

all Trace:
Hardware name: Dell Inc. PowerEdge SC1430/0HD812, BIOS 1.3.0 07/09/2007
CPU: 2 PID: 1914 Comm: CPU 1/KVM Not tainted 4.16.7-300.fc28.x86_64 #1
vmwrite error: reg 401e value 2020 (err 12)
 ? entry_SYSCALL_64_after_hwframe+0x3d/0xa2
 ? do_syscall_64+0x74/0x180
 ? SyS_ioctl+0x74/0x80
 ? do_vfs_ioctl+0xa4/0x610
 ? wake_up_q+0x70/0x70
 ? kvm_vcpu_ioctl+0x2b8/0x5e0 [kvm]
 ? _copy_to_user+0x26/0x30
 ? wake_up_q+0x70/0x70
 ? pollwake+0x74/0x90
 ? kvm_arch_vcpu_ioctl_run+0x504/0x1720 [kvm]
 ? __irqentry_text_start+0x8/0x8
 ? vmx_vcpu_run+0x7b7/0x990 [kvm_intel]
 ? vmx_vcpu_run+0x3e5/0x990 [kvm_intel]
 ? vmx_handle_exit+0xab/0xe10 [kvm_intel]
 handle_cr+0x5aa/0x630 [kvm_intel]
 kvm_set_cr4+0x18b/0x2e0 [kvm]
 ? vmx_vcpu_run+0x3d9/0x990 [kvm_intel]
 vmx_set_cr4+0x1dc/0x200 [kvm_intel]
 dump_stack+0x5c/0x85

As soon as I kill the VM the messages stop.

Version-Release number of selected component (if applicable):
4.16.7-300.fc28.x86_64

How reproducible:
100%

Steps to Reproduce:
1.virsh start vm
2.
3.

Comment 1 Jeremy Cline 2018-05-11 16:19:17 UTC
Hi Steve,

Thanks for the report. Can you test the 4.16.8 kernel[0] and leave karma? It should have the fix for this. If not, please re-open this bug.

[0] https://bodhi.fedoraproject.org/updates/FEDORA-2018-ac3b4c7605

*** This bug has been marked as a duplicate of bug 1566258 ***