Bug 1577405

Summary: '<CompositeObject>' object has no attribute 'FirewallEnabled'
Product: [Fedora] Fedora Reporter: Patrick Uiterwijk <puiterwijk>
Component: anacondaAssignee: Martin Kolman <mkolman>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 29CC: anaconda-maint-list, bcl, fzatlouk, jkonecny, jonathan, kellin, mkolman, pbrobinson, puiterwijk, robatino, rvykydal, sbueno, vanmeeuwen+fedora, v.podzimek+fedora, vponcova, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedFreezeException, RejectedBlocker
Fixed In Version: anaconda-29.15-1 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-09-09 11:37:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1517012    
Attachments:
Description Flags
oz log with traceback none

Description Patrick Uiterwijk 2018-05-11 22:04:04 UTC
Description of problem:
During the "Configure firewall" phase, the following traceback is thrown:

19:30:05,205 INFO anaconda:anaconda: installation: Task started: Configure firewall (8/19)
19:30:05,221 DEBUG anaconda:anaconda: exception: running handleException
19:30:05,222 CRIT anaconda:anaconda: exception: Traceback (most recent call last):#012#012  File "/usr/lib64/python3.6/site-packages/pyanaconda/threading.py", line 291, in run#012    threading.Thread.run(self)#012#012  File "/usr/lib64/python3.6/threading.py", line 864, in run#012    self._target(*self._args, **self._kwargs)#012#012  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation.py", line 200, in doConfiguration#012    configuration_queue.start()#012#012  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 304, in start#012    item.start()#012#012  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 304, in start#012    item.start()#012#012  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 472, in start#012    self.run_task()#012#012  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 438, in run_task#012    self._task(*self._task_args, **self._task_kwargs)#012#012  File "/usr/lib64/python3.6/site-packages/pyanaconda/kickstart.py", line 932, in execute#012    if firewall_proxy.FirewallEnabled:#012#012AttributeError: '<CompositeObject>' object has no attribute 'FirewallEnabled'

This crashes the installer.


Version-Release number of selected component (if applicable):
anaconda-29.14-1.fc29
pykickstart-3.13-1.fc29


Example: https://kojipkgs.fedoraproject.org//work/tasks/1119/26901119/oz-x86_64.log

Comment 1 Patrick Uiterwijk 2018-05-11 22:20:50 UTC
Created attachment 1435154 [details]
oz log with traceback

Attached the Oz log linked to, in case the compose gets cleaned up.

Comment 2 Fedora Blocker Bugs Application 2018-05-11 22:26:03 UTC
Proposed as a Freeze Exception for 29-beta by Fedora user puiterwijk using the blocker tracking app because:

 This prevents composing of the Container base images.

Comment 3 Patrick Uiterwijk 2018-05-11 22:36:43 UTC
Also proposing blocker, because while the container image isn't release blocking, I think that this is a probably problematic case.

Comment 4 Patrick Uiterwijk 2018-05-14 16:34:24 UTC
Working theory is that this is caused by the "--nocore" in the container kickstart, which means no firewalld.
So basically: no firewalld -> broken kickstart.

Comment 5 FrantiĊĦek Zatloukal 2018-05-14 22:31:25 UTC
Discussed during the 2018-05-14 blocker review meeting: [1]

The decision to classify this bug as an RejectedBlocker and AcceptedFreezeException was made:

"As currently understood, this does not affect any release-blocking image. If our understanding of the bug changes we will revisit this"

This bug was marked as automatic FreezeException as per QA:SOP[2]:

"These bugs can be marked as accepted by any member of one of the stakeholder groups without formal review"


[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-05-14/f29-blocker-review.2018-05-14-16.01.log.txt

[2] https://fedoraproject.org/wiki/QA:SOP_freeze_exception_bug_process#Automatic_freeze_exceptions

Comment 6 Martin Kolman 2018-05-15 09:56:32 UTC
PR: https://github.com/rhinstaller/anaconda/pull/1473

Comment 7 Jan Kurik 2018-08-14 11:19:18 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 8 Peter Robinson 2018-09-09 11:37:20 UTC
Closing this as current release as the latest anaconda in f29 is anaconda-29.24.1-1.fc29 and this was fixed in 29.15