Bug 1577528

Summary: Slowdown/absolute freeze of fedora computer at high memory usage
Product: [Fedora] Fedora Reporter: SlayerProof32 <korbin.freedman>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 28CC: airlied, bskeggs, ewk, hdegoede, ichavero, itamar, jarodwilson, jglisse, john.j5live, jonathan, josef, kernel-maint, linville, mchehab, mjg59, steved
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-07-23 17:23:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description SlayerProof32 2018-05-12 18:55:30 UTC
Description of problem: Fedora freezes on high memory usage, or system goes almost unresponsive


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Use up all system memory in your computer. I do this by opening up high ram usage tabs in firefox
2.Watch your computer freeze up
3. If the computer unfreezes, check for high Cpu load averages, and possibly low swap usage

Actual results:
Computer freezes on high ram usages, and cpu load average goes way up


Expected results:
Computer does not freeze. Either OOM killer kills non volatile processes, or more processes are swapped

Additional info:
Tested
E6400 with 2gb ram/ 2gb swap
I5-520m with 4gb ram/ 4gb swap

Info on how to debug behaviour like this would be appreciated

Comment 1 SlayerProof32 2018-05-13 00:31:11 UTC
What I believe happens is that all RAM is used first, then swap is used. This should really be, when ram is about 3/4 full, we start swapping everything that won't effect user performance so it is a lot harder to fill up ram

Comment 2 Justin M. Forbes 2018-07-23 15:11:25 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 28 kernel bugs.

Fedora 28 has now been rebased to 4.17.7-200.fc28.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 3 SlayerProof32 2018-07-23 17:23:03 UTC
No longer an issue. Fixed in 4.17.5