Bug 1578020

Summary: cinder volume attach: Include multipath tools
Product: Red Hat OpenStack Reporter: Rajini Karthik <rajini.karthik>
Component: python-os-brickAssignee: Alan Bishop <abishop>
Status: CLOSED ERRATA QA Contact: Avi Avraham <aavraham>
Severity: high Docs Contact: Kim Nylander <knylande>
Priority: high    
Version: 12.0 (Pike)CC: abishop, apevec, arkady_kanevsky, cdevine, christopher_dearborn, cschwede, dcain, eharney, jschluet, kurt_hey, lhh, m.andre, mburns, morazi, pgrist, rajini.karthik, randy_perryman, scohen, smerrow, sreichar, sumedh_sathaye, thiago, tshefi
Target Milestone: betaKeywords: Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-os-brick-2.3.0-1.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:56:23 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1476902, 1577362    

Description Rajini Karthik 2018-05-14 16:10:41 UTC
Description of problem:

The cinder-volume container needs to attach the volume and copy the image into to the volume. This behavior is just like the one of nova-compute container, the only difference is that nova attaches the volume for VM instances.

All the cinder drivers (including dellemc) support `boot from image` and etc. use cases. They would be configured to use multipath and will encounter the `multipath not installed` issue. So,it is a common library and should be installed the common base image.

This is a request from the customer using Multipath with VNX customer container

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Rajini Karthik 2018-05-14 20:56:36 UTC
(In reply to Rajini Karthik from comment #0)
> Description of problem:
> 
> The cinder-volume container needs to attach the volume and copy the image
> into to the volume. This behavior is just like the one of nova-compute
> container, the only difference is that nova attaches the volume for VM
> instances.
> 
> All the cinder drivers (including dellemc) support `boot from image` and
> etc. use cases. They would be configured to use multipath and will encounter
> the `multipath not installed` issue. So,it is a common library and should be
> installed the common base image.
> 
> This is a request from the customer using Multipath with VNX customer
> container
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
> 
> Actual results:
> 
> 
> Expected results:
> 
> 
> Additional info:

Comment 2 Rajini Karthik 2018-05-23 19:40:17 UTC
The volume from image issue is due to the configuration specifying 
>image transfer uses multipath. The cinder-volume docker image does not 
>contain multipath tools
$ sudo docker exec -u 0 cinder_volume which multipath
>    which: no multipath in
>(/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin)
>    
>    This can be resolved by 1) setting the "use_multipath_for_image_xfer"
>parameter to False or 2) installing device-mapper-multipath in the image.

Comment 3 Alan Bishop 2018-05-31 17:43:20 UTC
I chased this down to a missing RPM dependency that has already been fixed in upstream RDO [1].

[1] https://review.rdoproject.org/r/#/c/13171

Sean, this is something we need to get into OSP-13 ASAP. It's a low-risk change that only affects the python-os-brick RPM spec file (no code changes).

Comment 7 Alan Bishop 2018-05-31 18:46:15 UTC
Well that was easy. The upstream patch has already been backported to OSP-13 (see bug 1560244 comment #1).

Moving this directly to ON_QA so they can sign off on this. The fix is already present in OSP-13 beta.

Comment 12 Tzach Shefi 2018-06-04 10:16:49 UTC
Verified on:
python2-os-brick-2.3.1-1.el7ost.noarch

inside c-vol docker:
docker exec -t openstack-cinder-volume-docker-0 which multipath
/usr/sbin/multipath

multipath tool also present in remaining Cinder containers.

[root@controller-0 ~]# docker exec -t cinder_api which multipath
/usr/sbin/multipath
[root@controller-0 ~]# docker exec -t cinder_scheduler which multipath
/usr/sbin/multipath
[root@controller-0 ~]# docker exec -t cinder_api_cron which multipath
/usr/sbin/multipath

Comment 15 errata-xmlrpc 2018-06-27 13:56:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086