Bug 1581058

Summary: [3.10]Failed to deploy clustered ES pods
Product: OpenShift Container Platform Reporter: Qiaoling Tang <qitang>
Component: LoggingAssignee: ewolinet
Status: CLOSED ERRATA QA Contact: Qiaoling Tang <qitang>
Severity: high Docs Contact:
Priority: high    
Version: 3.10.0CC: anli, aos-bugs, eminguez, ewolinet, jcantril, juzhao, mifiedle, mmckinst, pkanthal, pportant, qitang, rmeggins, sdodson, tlarsson, xtian
Target Milestone: ---Keywords: TestBlocker
Target Release: 3.10.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: 1540099 Environment:
Last Closed: 2018-07-30 19:16:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1540099    
Bug Blocks: 1544243, 1578605    

Comment 1 Qiaoling Tang 2018-05-22 06:12:34 UTC
Version-Release number of selected component (if applicable):
openshift v3.10.0-0.50.0

openshift-ansible-3.10.0-0.50.0.git.0.bd68ade.el7.noarch

Comment 8 Mike Fiedler 2018-05-24 13:44:31 UTC
I hit this as well using openshift-ansible master latest (as of 24 May) and with openshift-ansible 3.10.0-0.50.0.   After downgrading to openshift-ansible 3.10.0-0.47.0 the install worked.

[2018-05-24 13:03:30,878][ERROR][com.floragunn.searchguard.action.configupdate.TransportConfigUpdateAction] [logging-es-data-master-3lnl2ws1] Failure while checking .searchguard.logging-es-data-master-3lnl2ws1 index MasterNotDiscoveredException[null]
MasterNotDiscoveredException[null]
        at org.elasticsearch.action.support.master.TransportMasterNodeAction$AsyncSingleAction$5.onTimeout(TransportMasterNodeAction.java:234)
        at org.elasticsearch.cluster.ClusterStateObserver$ObserverClusterStateListener.onTimeout(ClusterStateObserver.java:236)
        at org.elasticsearch.cluster.service.InternalClusterService$NotifyTimeout.run(InternalClusterService.java:816)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
        at java.lang.Thread.run(Thread.java:748)

Comment 10 Anping Li 2018-06-05 06:33:47 UTC
Block testing about clustered ES related cases

Comment 13 Qiaoling Tang 2018-06-06 03:21:25 UTC
Verified on openshift v3.10.0-0.60.0.

Comment 15 errata-xmlrpc 2018-07-30 19:16:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816